1102 Invert a Binary Tree (25分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

思路:bfs可以得到层序遍历,dfs得到 “右节点-根-左节点” 的顺序的遍历。

#include<bits/stdc++.h>
using namespace std;
struct node{
    int l,r;
    node():l(-1),r(-1){}
};
node t[20];
vector<int> fin;
int bin[20];
void rein(int rt){
    if(t[rt].r!=-1) rein(t[rt].r);
    fin.push_back(rt);
    if(t[rt].l!=-1) rein(t[rt].l);
}
int findFather(int x){
    if(bin[x]==x) return x;
    else return bin[x]=findFather(bin[x]);
}
int main(){
    int n;
    char a,b,c,d,e;
    scanf("%d", &n);getchar();
    for(int i=0; i<n; ++i) bin[i]=i;
    for(int i=0; i<n; ++i){
        char a,b;
        scanf("%c %c", &a, &b);getchar();
        if(a!='-'){
            t[i].l = (int)(a-'0');
            bin[t[i].l]=findFather(i);
        }
        if(b!='-'){
            t[i].r = (int)(b-'0');
            bin[t[i].r]=findFather(i);
        }
    }
    int root;
    for(int i=0;i<n;++i){
        if(bin[i]==i){
            root = i;
            break;
        }
    }
    vector<int> lev;
    queue<int> que;
    que.push(root);
    while(!que.empty()){
        int now = que.front();
        lev.push_back(now);
        que.pop();
        if(t[now].r!=-1) que.push(t[now].r);
        if(t[now].l!=-1) que.push(t[now].l);
    }
    for(int i=0; i<n; ++i){
        if(i) printf(" ");
        printf("%d", lev[i]);
    }
    puts("");
    rein(root);
    for(int i=0; i<n; ++i){
        if(i) printf(" ");
        printf("%d", fin[i]);
    }
    puts("");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值