1102 Invert a Binary Tree (25 分)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题意

  1. invert——反转二叉树
  2. 然而开始并没有看到这个invert,于是噼里啪啦写完之后,发现答案完全不对,然后把答案画了画和自己的对照才发现它的左右节点反转了
  3. 于是以为题目是先输入右节点再输入左节点,于是就修改下面的地方:
    scanf("%c%c%c",&r,&ch,&l);
    

是的,仅仅将左右节点输入对调

  1. 一顿操作猛如虎,就这样AC
  2. 常规思路下次再写吧QAQ

code

#include<iostream>
#include <bits/stdc++.h>
using namespace std;

struct node
{
    //int data;
    int l_child, r_child;
}Node[11];

int n;
int in[11];
int num = 0;

void levelOrder(int root);
void inOrder(int root);

int main()
{
    char l,r,ch;
    int root;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        getchar();
        scanf("%c%c%c",&r,&ch,&l);
        Node[i].l_child = l=='-'? -1 : l - '0';
        Node[i].r_child = r=='-'? -1 : r - '0';
        if(Node[i].l_child != -1){
            in[Node[i].l_child]++;
        }
        if(Node[i].r_child != -1){
            in[Node[i].r_child]++;
        }
    }
    for(int i = 0; i < n; i++){
        if(in[i]==0) {
            root = i;
            break;
        }
    }
    levelOrder(root);
    putchar('\n');
    num = 0; //
    inOrder(root);
    return 0;
}

void levelOrder(int root)
{
    queue<int> q;
    q.push(root);
    num = 0;
    while(!q.empty()){
        int now = q.front();
        q.pop();
        printf("%d",now);
        num++;
        if(num < n) printf(" ");
        if(Node[now].l_child != -1) q.push(Node[now].l_child);
        if(Node[now].r_child != -1) q.push(Node[now].r_child);
    }
}

void inOrder(int root)
{
    if(root == -1) return;
    inOrder(Node[root].l_child);
    num++;
    printf("%d",root);
    if(num < n) printf(" ");
    inOrder(Node[root].r_child);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值