课程练习二-1002

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2<br>100<br>200
 

Sample Output
  
  
-74.4291<br>-178.8534
 

Author
Redow
 
题意:输入Y, 根据公式  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-Y*x (0<=x<=100),求出   F(x)的最小值。


思路:先求导得到:f(x)=42*x^6+48*x^5+21*x^2+10*x-Y 。然后根据数学知识,判断F(x)的增减性。

然后根据Problem A的做法就ok了。(二分查找法)


代码:

#include<iostream>
#include<iomanip>
#include<cmath>
#include<stdlib.h>
using namespace std;
int main()
{
int T;
cin>>T;
for(int i=0;i<T;i++)
{
int Y;
cin>>Y;
double max=100;
double min=0;
if(42*pow(100,6)+48*pow(100,5)+21*pow(100,2)+10<Y)
cout<<setprecision(4)<<fixed<<100.0<<endl;
else if(0>Y)
{
cout<<setprecision(4)<<fixed<<0.0<<endl;
}
else{
while((max-min)>0.000001)
{
double x=(max+min)/2;
if(42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x>Y)
max=x;
else min=x;
if((max-min)<0.00001)
{
cout<<setprecision(4)<<fixed<<6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-Y*x<<endl;
break;
}
}
 }
}

system("pause");
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值