问题 : I-number

题目描述

The I-number of x is defined to be an integer y, which satisfied the the conditions below:
1. y>x;
2. the sum of each digit of y(under base 10) is the multiple of 10;
3. among all integers that satisfy the two conditions above, y shouble be the minimum.
Given x, you're required to calculate the I-number of x.

输入

An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
The following T lines describe all the queries, each with a positive integer x. The length of x will not exceed 105.

输出

Output the I-number of x for each query.

样例输入

1
202

样例输出

208

题意懂了,就是一个水题,不懂你就过不了,这个题有三个条件

1   y>x
2   每一位的和相加是10的倍数
3  输出最小的y

代码:

# include <stdio.h>

int qwe(int x)  // 每一位的和
{
	int sum = 0;  
	while (x != 0)
	{
		sum += x%10;
		x /= 10;
	}
	return sum;
}

int main(void)
{
	int t;
	scanf("%d", &t);
	while (t --)
	{
		int n, c;
		scanf("%d", &n);
		n ++;
		while (1)
		{
			c = qwe(n);
			if (c % 10 == 0) // 满足结束,输出
			{
				printf("%d\n", n);
				break;
			}
			n ++; // 不满足继续加。
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值