B - 报数游戏

B - 报数游戏
Time Limit:1000MS    Memory Limit:65535KB    64bit IO Format:%I64d & %I64u

Description

n个人站成一行玩一个报数游戏。所有人从左到右编号为1到n。游戏开始时,最左边的人报1,他右边的人报2,编号为3的人报3,等等。当编号为n的人(即最右边的人)报完n之后,轮到他左边的人(即编号为n-1的人)报n+1,然后编号为n-2的人报n+2,以此类推。当最左边的人再次报数之后,报数方向又变成从左到右,依次类推。
为了防止游戏太无聊,报数时有一个特例:如果应该报的数包含数字7或者是7的倍数,他应当用拍手代替报数。下表是n=4的报数情况(X表示拍手)。当编号为3的人第4次拍手的时候,他实际上数到了35。

给定n,m和k,你的任务是计算当编号为m的人第k次拍手时,他实际上数到了几。

Input

输入包含不超过10组数据。每组数据占一行,包含三个整数n,m和k(2<=n<=100, 1<=m<=n, 1<=k<=100)。输入结束标志为n=m=k=0。

Output

对于每组数据,输出一行,即编号为m的人第k次拍手时,他实际上数到的那个整数。

Sample Input

4 3 1 
4 3 2 
4 3 3 
4 3 4 
0 0 0 

Sample Output

17 
21 
27 
35

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int num,temp,res,flag,count1,n,m,k;

int main()
{
    int i;
    while(true)
    {
        scanf("%d%d%d",&n,&m,&k);
        if(n==0&&m==0&&k==0)
        {
            break;
        }
        count1=0;
        num=0;
        B:while(count1<k)
        {
            A:for(i=1;i<=n;i++)
            {
                flag=0;
                num++;
                temp=num;
                while(temp)
                {
                    res=temp%10;
                    if(res==7)
                    {
                        flag=1;
                    }
                    temp/=10;
                }
                if(num%7==0)
                {
                    flag=1;
                }
                if(flag&&i==m)
                {
                    count1++;
                    if(count1==k)
                    {
                        goto B;
                    }
                }
            }
            for(i=n-1;i>=2;i--)
            {
                flag=0;
                num++;
                temp=num;
                while(temp)
                {
                    res=temp%10;
                    if(res==7)
                    {
                        flag=1;
                    }
                    temp/=10;
                }
                if(num%7==0)
                {
                    flag=1;
                }
                if(flag&&i==m)
                {
                    count1++;
                    if(count1==k)
                    {
                        goto B;
                    }
                }
                if(i==2)
                {
                    goto A;
                }
            }
        }
        printf("%d\n",num);
    }
    return 0;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值