zoj 2326 Tangled in Cables【最小生成树 kruskal && prim】

Tangled in Cables

Time Limit: 2 Seconds       Memory Limit: 65536 KB

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.


Input

Only one town will be given in an input.

  • The first line gives the length of cable on the spool as a real number.

  • The second line contains the number of houses, N

  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a�Cz,A�CZ,0�C9} and contains no whitespace or punctuation.

  • Next line: M, number of paths between houses

  • next M lines in the form
    <house name A> <house name B> <distance>
    Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output

Not enough cable

If there is enough cable, then output

Need <X> miles of cable

Print X to the nearest tenth of a mile (0.1).


Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0


Sample Output

Need 10.2 miles of cable


这道题需要对字符串进行处理,刚开始 prim 没做出来后来发现起始点不定为0就行了。

另外这个题没说范围,数组不要开太大500以内即可。


kruskal:

#include<cstdio>
#include<cstring>
#include<cmath>
#define cle(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Sf(a) scanf("%lf", &a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("Need %.1lf miles of cable\n", (a))
#define INF 0x3f3f3f
#include<algorithm>
using namespace std;
const int mx = 10010;
int per[mx];

void init()
{
	for(int i = 0; i < mx; i++)
		per[i] = i;
} 
struct node{
	int start, end;
	double val;
};
node p[10010];
bool operator < (node a, node b)
{
	return a.val < b.val;
}
int find(int x)
{
	return x==per[x] ? x : (per[x] = find(per[x]));
}
bool join(int x, int y)
{
	int fx = find(x);
	int fy = find(y);
	if( fx != fy)
	{
		per[fx] = fy;
		return true;
	}
	return false;
}
int main(){
	init();
	double len;  Sf(len);
	int n;  Si(n);
	char ch[5500][25];
	int i, j, k;
	for(i = 0; i < n; i++)
	{
		scanf("%s", ch[i]);
	}
	int m;  Si(m);
	char b[25], c[25];
	double d; 
	for(i = 0; i < m; i++)
	{
		scanf("%s%s%lf", b, c, &p[i].val);
		for(j = 0; j < n; j++)
		{
			if(!strcmp(b, ch[j]))	p[i].start = j;
			if(!strcmp(c, ch[j]))	p[i].end = j;
		}
		
	}
	sort(p, p+m);
	double ans = 0.0;
	for(i = 0; i < m; i++)//遍历每条路 
	{
		if(join(p[i].start, p[i].end))
			ans += p[i].val;
	}
	if(ans > len)	puts("Not enough cable");
	else	Pf(ans);
	return 0;
}


prim:

#include<cstdio>
#include<cstring>
#include<cmath>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Sf(a) scanf("%lf", &a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("Need %.1lf miles of cable\n", (a))
#define INF 0x3f3f3f
const int mx = 310;
double map[mx][mx];
char ch[mx][25];
int n, m;	//n city, m road 
int vis[mx];
double len;	
double val[mx];
void prim()
{
	mem(vis, 0);
	int i, j, k;
	double minn, ans = 0.0;
	for(i = 1; i <= n; i++)
		val[i] = map[1][i];
	vis[1] = 1;
	for(i = 1; i < n; i++)
	{
		k = 1; minn = INF;	
		for(j = 1; j <= n; j++)
		{
			if(!vis[j] && val[j] < minn)
			{
				minn = val[j];
				k = j;
			}
		}
		if(minn == INF){
			ans = -1;	break;
		}
		vis[k] = 1;
		ans += minn;	
		for(j = 1; j <= n; j++)
		{
			if(!vis[j] && val[j] > map[j][k])
				val[j] = map[j][k];	
		}
	}	
	if(ans == -1 || ans > len)	puts("Not enough cable");
	else  Pf(ans); 
}
int main(){
	int i, j, k;
	
	Sf(len);	Si(n); 
	for(i = 1; i <= n; i++)
	{
		for(j = 1; j <= n; j++)
		{
			map[i][j] = INF;
		}
		map[i][i] = 0;
	}
	char a[25], b[25];
	for(i = 1; i <= n; i++)
	{
		scanf("%s", ch[i]);
	}
	Si(m);
	double d;
	int s, e;
	for(i = 1; i <= m; i++)
	{
		scanf("%s%s%lf", a, b, &d);
		s = e = 0;
		for(j = 1; j <= n; j++)
		{
			if(!strcmp(a, ch[j]))	s = j;
			if(!strcmp(b, ch[j]))	e = j;
		}
		map[s][e] = map[e][s] = d;
	}
	prim(); 
	return 0;
} 


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值