zoj 1914 || poj 2349 Arctic Network【最小生成树 kruskal && prim】

Arctic Network

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.


Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).


Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.


Sample Input

1
2 4
0 100
0 300
0 600
150 750


Sample Output

212.13




题意:有两种不同的通信技术,用卫星通信的两个城市之间可以任意联络,但用无线电通信的城市只能和距离不超过D的城市联系。无线电的传输距离D越大,花费就越多。已知无线电的数目,让求最小的D,使得没有卫星的城市都可以使用无线电。


kruskal:

#include<cstdio>
#include<cstring>
#include<cmath>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define INF 0x3f3f3f
#include<algorithm>
using namespace std;
const int mx = 1010;
int per[mx];
void init()
{
    for(int i = 0; i < mx; i++)
        per[i] = i;
}
struct node
{
    int start, end;
    double val;
};
node q[1000100];//之前开的不够大 提交后 Segmentation Fault 
bool operator < (node a,node b)
{
    return a.val < b.val;
}
int find(int x)
{
    return x == per[x] ? x : (per[x] = find(per[x]));    
}
bool join(int x,int y)
{
    int fx = find(x);
    int fy = find(y);
    if(fx != fy)
    {
        per[fx] = fy;
        return true;
    }
    return false;
}
double x[mx], y[mx];
int main(){
	int t;	Si(t);
	Wi(t){
		init();
		int s, p, i, j, k;
		scanf("%d%d", &s, &p);
		for(i = 0; i < p; i++)
		{
			scanf("%lf%lf", &x[i], &y[i]);
		}
		for(i = 0, k = 0; i < p; i++)
		{
			for(j = i+1; j < p; j++)
			{
				q[k].start = i;
				q[k].end = j;
				q[k].val = sqrt( (x[i]-x[j])*(x[i]-x[j]) + (y[i]-y[j])*(y[i]-y[j]));
				k++;
			}
		}
		sort(q, q+k);
		int num = 0;
		double cost;
		for(i = 0; i < k; i++)
		{
			if(join(q[i].start, q[i].end))	num++;
			if(num == p-s)
			{
				cost = q[i].val;	break;
			}
		}
		Pf(cost);
	}
	return 0;
}

prim:

#include<cstdio>
#include<cstring>
#include<cmath>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pf(a) printf("%.2lf\n", (a))
#define INF 0x3f3f3f
#include<algorithm>
using namespace std;
const int mx = 1010;
double map[mx][mx];
double val[mx], dis[mx];//两个数组都是记录权值的 
int vis[mx]; 
int m, n;
int cmp(const double &a, const double &b)
{
	return a > b;
}
void prim()
{
	mem(vis, 0);
	int i, j, k;
	double minn;
	int t = 0;
	for(i = 1; i <= n; i++)
		dis[i] = map[1][i];
	vis[1] = 1;
	for(i = 1; i < n; i++)
	{
		k = 1; minn = INF;
		for(j = 1; j <= n; j++)
		{
			if(!vis[j] && minn > dis[j])
			{
				minn = dis[j];
				k = j;
			}
		}
		vis[k] = 1;
		val[t++] = dis[k];
		for(j = 1; j <= n; j++)
		{
			if(!vis[j] && dis[j] > map[j][k])
				dis[j] = map[j][k];
		}
	}
	sort(val, val+t, cmp);//对val从大到小排序 
	Pf(val[m-1]);	//输出除去卫星连接的边的最大边权值 
}
double x[mx],y[mx]; 
int main()
{
	int t;	 Si(t);
	Wi(t){
		scanf("%d%d", &m, &n);
		int i, j, k;
		for(i = 1; i <= n; i++)
		{
			for(j = 1; j <= n; j++)
				map[i][j] = (i==j?0:INF);
		}
		for(i = 1; i <= n; i++)
		{
			scanf("%lf%lf", &x[i], &y[i]);
		}
		for(i = 1; i <= n; i++)
		{
			for(j = i+1; j <= n; j++)
			{
				map[i][j] = map[j][i] = sqrt( (x[i]-x[j])*(x[i]-x[j]) + (y[i]-y[j])*(y[i]-y[j]));
			}
		}
		prim();
	}
	return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值