NYOJ 103 A+B Problem II(附带题目翻译)

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
题目大意:这个题就是说现在有两个数,位数可能很大,但不超过100位,求这两个数相加的和。
                           第一行输入1<=T<=20,表示有几组测试数据,第二行输入两个数,空格隔开,

             输出:第一行是输出Case i:  (i=1、2、3........) Case和i之间有空格,第二行输出原来的第一个数、空格、+、空格、第二个数、空格、=、空格、两数 的和。

解题思路:因为计算机是读取不了位数很大的数,所以要利用字符串读取,并用数组存放计算结果来模拟加法过程。从两个字符串的末位开始依次往前计算,并把   每次计算的结果存放到数组中,最后逆序输出数组元素即可。
具体代码:
#include <stdio.h>
#include <string.h>
char a[1005];
char b[1005];
int c[1005];
int main()
{
	int T,t=0;
	scanf("%d",&T);
	getchar();
	while(T--)
	{
		memset(c,0,sizeof(c));//初始化 
		scanf("%s%s",a,b);
		int la=strlen(a);
		int lb=strlen(b);
		int i,j,s,k=0,v=0;
		for(i=la-1,j=lb-1;;i--,j--)
		{
			if(i<0&&j<0)
			//当两个字符串的第一位都计算完后退出循环
				break; 
			if(i<0)
			//字符串a算完了,但b还没完(b的位数比a多)
				s=(b[j]-'0')+v;
			else if(j<0)//与上面相反 
				s=(a[i]-'0')+v;
			else
				s=(a[i]-'0')+(b[j]-'0')+v;
			c[k]=s%10;
			v=s/10;//计算进位 
			if((i==0&&j<=0||i<=0&&j==0)&&v!=0)
			//当首位算完后,还有进位,则把最后的进位存放起来 
				c[++k]=v;
			k++;
		}
		printf("Case %d:\n",++t);
		printf("%s + %s = ",a,b);
		for(i=k-1;i>=0;i--)
			printf("%d",c[i]);
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值