A + B Problem II(大数加法hd1002)

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<string>
#include<fstream>
#define N 1000
using namespace std;


string bigmult(string a,string b)
{
    int la,lb,lc,i,j,flag;
    string c="";
    char t;
    i=la=a.length()-1;        //i,j为两个字符串的长度 
    j=lb=b.length()-1;		   
    flag=0;
    while(i>=0&&j>=0)		//当两个数都还有数位没加时,进行此循环 
    {
        t=a[i]+b[j]+flag-'0';
        if(t>'9') 
        {
            t=t-10;flag=1;
        }
        else flag=0;
        c+=t;	           //每加一次,就在字符串c后面接上一个t 
        i--;j--;
    }		
    while(i>=0)				 //仅一个数还有数位没加 
    {
        t=a[i]+flag;         
        if(t>'9')
        {
            t=t-10;flag=1;
        }
        else flag=0;
        c+=t;
        i--;
    }
    while(j>=0)
    {
        t=b[j]+flag;
        if(t>'9')
        {
            t=t-10;flag=1;
        }
        else flag=0;
        c+=t;
        j--;
    }
    if(flag) c+=(flag+'0');
    lc=c.length();
    for(i=0,j=lc-1;i<j;i++,j--)   //倒序排列 
    {
        t=c[i];c[i]=c[j];c[j]=t;
    }
    return c;
}

int main()
{
    int test,k=1;
    string a,b;
    cin>>test;
    while(test--)
    {
        cin>>a>>b;
        cout<<"Case "<<k++<<":"<<endl;
        cout<<a<<" + "<<b<<" = "<<bigmult(a,b)<<endl;
        if(test)cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值