poj 1552 Doubles

Doubles
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17946 Accepted: 10377

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list 
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9. 
给出2到15个不同的正整数,计算在这些数里面有多少数据对满足一个数是另一个数的两倍。比如给出:
1 4 3 2 9 7 18 22
答案是3, 因为2是1的两倍,4是2的两倍, 18是9的两倍。

Input

The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
输入包括多组输入数据。每组数据包括一行,给出2到15个两两不同且大于0小于100的正整数。每一行最后一个数是0,表示这一行的结束。输入的最后一行只包括一个整数-1,这行表示输入数据的结束,不用进行处理。

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.
对每组输入数据, 输出一行, 给出有多少个数对,满足其中一个数是另一个数的两倍。

Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0

Source


水题。。。直接暴力通过就好。。。
#include <iostream>
#include <stdio.h>


int main(){
    int a[20];
    int count_num = 0;
    int i = 0;

    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);

    scanf("%d", &a[0]);
    while(a[0] != -1){

        for (i = 1;; i++){
            scanf("%d", &a[i]);
            if (a[i] == 0)
                break;
        }
        count_num = 0;
        for (int j = 0;j < i - 1;j ++){
            for (int k = j + 1; k < i;k ++){
                if (a[j] == a[k] * 2 || a[k] == a[j] * 2){
                    count_num ++;
                }
            }
        }
        printf("%d\n", count_num);
        scanf("%d", &a[0]);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值