openjudge2106 Boolean Expressions

Description

The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next: 
Expression: ( V | V ) & F & ( F | V )

where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed. 

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file. 

Input

The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown. 

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below. 

Output

For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line. 

Use the same format as that shown in the sample output shown below. 

Sample Input

( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))

Sample Output

Expression 1: F
Expression 2: V
Expression 3: V


#include<iostream>
#include<cstdio>
#include<stack>
#include<queue>
#include<string>
using namespace std;

stack<char> s;
queue<char> q;  //存后缀表达式 
string c;
		
int f(char c){  //求表达式的优先级
	if(c=='(') return 4;
	if(c=='!') return 3;
	if(c=='&') return 2;
	if(c=='|') return 1; 
} 
 
int f2(char c){  //转换F和V 
	if(c=='F') return 0;
	else return 1; 
}

void houzui(){   //求表达式对应的后缀表达式 
	while(s.size()){
		s.pop();
	}
	for(int i=0;i<c.size();i++){
		if(c[i]!=' '){  //除去空格 
			if(c[i]=='F'||c[i]=='V') q.push(c[i]);       
			else if(c[i]=='!'&&s.size()&&s.top()=='!'){  //除去两个连续的'!' 
				s.pop();
			}
			else if(!s.size()) s.push(c[i]);
			else if(c[i]==')'){           //如果是右括号,则弹出对应左括号前的所有的运算符 
				while(s.top()!='('){
					q.push(s.top());
					s.pop();
				}
				s.pop();
				continue;
			}
			else if(f(s.top())==4||(f(c[i])>f(s.top()))) s.push(c[i]);  //左括号优先级最高,入栈后优先级最低 
			else if(f(s.top())!=4&&f(c[i])<=f(s.top())){
				q.push(s.top());
				s.pop();
				while(s.size()&&f(s.top())!=4&&f(c[i])<=f(s.top())){      //弹出不低于c[i]优先级的运算 
					q.push(s.top());
					s.pop();
				}
				s.push(c[i]);
			}
		}
	}
	while(s.size()){
		q.push(s.top());
		s.pop();
	}
}

void qiuzhi(){     //后缀表达式求值 
	bool r=1;
    char x,y;
	while(q.size()){
		if(q.front()=='V'||q.front()=='F') {
		s.push(q.front());
		q.pop();}
		else{
			if(q.front()=='&') {
				x=s.top();
				s.pop();
				y=s.top();
				s.pop();
				r=f2(x)&&f2(y);
				if(r==1)
				s.push('V');
				else
				s.push('F');
			}
			else if(q.front()=='|'){
				x=s.top();
				s.pop();
				y=s.top();
				s.pop();
				r=f2(x)||f2(y);
				if(r==1)
				s.push('V');
				else
				s.push('F');
			}
			else{  //!运算 
				x=s.top();
				s.pop();
				if(f2(x)==1)
				s.push('F');
				else
				s.push('V');
			}
			q.pop();
		}
	}
}

int main(){
	int flag=0;        //统计次数 
	while(getline(cin,c)){
		flag++;
	houzui();
	qiuzhi();
	cout<<"Expression "<<flag<<": "<<s.top()<<endl;
	}
	return 0;
}

附测试数据

F &!F |  !V|!V  & !F& !(  F | F& (V |  !F| !V| V& (V|F)))
F& !F|!V|!F&  (V|F| !V) & !F&!(F|F& (V | !F|!V|  V &(V| F)  ))
F&!F  | !V| !F&  !!!(  V|F| !V) & !F&!(F|F&  (V|!F|!V|V&(V|F)))
!V|!F&! (V|(F | V )| !V)& !F& !!(F| F& (V|!F|!V|V&(  V| F )))
(F|(F&V)|!V)&!F&! (F|(F&( V| !F|!V |V& (V |F)) ))
V
(((V)))
((!(F)))
(!(!(   !(F ))))
!!F|!F&!(V|(F|V)|!V)&!F&!!(F|F&(V|!F|!V|V&(V|F)))|((!(F)))

Expression 1: F
Expression 2: V
Expression 3: F
Expression 4: F
Expression 5: F
Expression 6: V
Expression 7: V
Expression 8: V
Expression 9: V
Expression 10: V



  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值