poj 2106 Boolean Expressions(模拟)

22 篇文章 0 订阅
Boolean Expressions

Description

The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next: 
Expression: ( V | V ) & F & ( F | V )

where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed. 

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file. 

Input

The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown. 

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below. 

Output

For each test expression, print "Expression " followed by its sequence number, ": ", and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line. 

Use the same format as that shown in the sample output shown below. 

Sample Input

( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))

Sample Output

Expression 1: F
Expression 2: V
Expression 3: V

ps:算是大模拟题了,判断条件比较多,用了一个小时才写完0.0,可惜比赛的时候没看

题意:给一串字符串,运算类似于数学上的且或反,F为假,V为真,问,最后表达式所表达的结果为真还是为假

思路:从字符串首位开始判断,遇到括号就先判断括号里面的并求出值,然后更新结果继续进行判断

代码:
#include<stdio.h>
#include<math.h>
#include<queue>
#include<map>
#include<stdlib.h>
#include<iostream>
#include<stack>
#include<string.h>
#include<algorithm>
using namespace std;

#define min(a,b) (a<b?a:b)
#define max(a,b) (a>b?a:b)
#define LL long long int
const int inf=0x3f3f3f3f;
#define maxn 100+10

char s[maxn];
int len;

int judge(int n)//与solve里同理
{
    int flag;
    for(int i=n; i<len&&s[i]!=')'; i++)
    {
        if(s[i]=='(')
        {
            flag=judge(i+1);
            while(s[i]!=')')
                i++;
        }
        else if(s[i]=='V')
            flag=1;
        else if(s[i]=='F')
            flag=0;
        else if(s[i]=='!')
        {
            i++;
            if(s[i]==' ')
                i++;
            if(s[i]=='(')
            {
                flag=!judge(i+1);
                while(s[i]!=')')
                    i++;
            }
            else if(s[i]=='F')
                flag=1;
            else if(s[i]=='V')
                flag=0;
        }
        else if(s[i]=='|')
        {
            i++;
            if(s[i]==' ')
                i++;
            if(s[i]=='(')
            {
                flag=(flag||(judge(i+1)));
                while(s[i]!=')')
                    i++;
            }
            else if(s[i]=='!')
            {
                i++;
                if(s[i]=='V')
                    flag=flag;
                else if(s[i]=='F')
                    flag=1;
                else if(s[i]=='(')
                {
                    flag=flag&&!(judge(i+1));
                    while(s[i]!=')')
                        i++;
                }
            }
            else if(s[i]=='F')
                flag=flag;
            else if(s[i]=='V')
                flag=1;
        }
        else if(s[i]=='&')
        {
            i++;
            if(s[i]==' ')
                i++;
            if(s[i]=='(')
            {
                flag=(flag&&(judge(i+1)));
                while(s[i]!=')')
                    i++;
            }
            else if(s[i]=='!')
            {
                i++;
                if(s[i]=='V')
                    flag=0;
                else if(s[i]=='F')
                    flag=flag;
                else if(s[i]=='(')
                {
                    flag=flag&&!(judge(i+1));
                    while(s[i]!=')')
                        i++;
                }
            }
            else if(s[i]=='F')
                flag=0;
            else if(s[i]=='V')
                flag=flag;
        }
//        printf("i=%d flag=%d\n",i,flag);
    }
    return flag;
}

int solve()
{
    len=strlen(s);
    int flag,flog;
    for(int i=0; i<len; i++)
    {
        if(s[i]=='(')//是左括号就进入括号,先判断括号里面的
        {
            flag=judge(i+1);
            while(s[i]!=')')//下标移动到右括号
                i++;
        }
        else if(s[i]=='V')
            flag=1;
        else if(s[i]=='F')
            flag=0;
        else if(s[i]=='!')
        {
            i++;
            if(s[i]=='(')
            {
                flag=!judge(i+1);
                while(s[i]!=')')
                    i++;
            }
            else if(s[i]=='F')//取反
                flag=1;
            else if(s[i]=='V')//取反
                flag=0;
        }
        else if(s[i]=='|')
        {
            i++;
            if(s[i]==' ')//跳过空格
                i++;
            if(s[i]=='(')
            {
                flag=(flag||(judge(i+1)));
                while(s[i]!=')')
                    i++;
            }
            else if(s[i]=='!')
            {
                i++;
                if(s[i]=='V')//要同时考虑 或 和 反
                    flag=flag;
                else if(s[i]=='F')//考虑到 或 和 反, 不论前面是什么,必为1
                    flag=1;
                else if(s[i]=='(')
                {
                    flag=flag&&!(judge(i+1));
                    while(s[i]!=')')
                        i++;
                }
            }
            else if(s[i]=='F')
                flag=flag;
            else if(s[i]=='V')
                flag=1;
        }
        else if(s[i]=='&')
        {
            i++;
            if(s[i]==' ')
                i++;
            if(s[i]=='(')
            {
//                printf("123v flag=%d\n",flag);
                flag=(flag&&(judge(i+1)));
                while(s[i]!=')')
                    i++;
            }
            else if(s[i]=='!')//注意要同时考虑 且 和 反
            {
                i++;
                if(s[i]=='V')
                    flag=0;
                else if(s[i]=='F')
                    flag=flag;
                else if(s[i]=='(')
                {
                    flag=flag&&!(judge(i+1));
                    while(s[i]!=')')
                        i++;
                }
            }
            else if(s[i]=='F')
                flag=0;
            else if(s[i]=='V')
                flag=flag;
        }
//        printf("i=%d flag=%d\n",i,flag);
    }
    return flag;
}

int main()
{
    int t=1;
    while(gets(s))
    {
        int ans=solve();
        char w;
        if(ans)
            w='V';
        else w='F';
        printf("Expression %d: %c\n",t++,w);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值