4324 Triangle LOVE


Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3543    Accepted Submission(s): 1382


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No

简单的拓扑排序,这个题出的有问题,只需要判断是否出现环就可以了,不需要判断是三元还是多元环.....

也就是在所有的元素都未遍历完全的时候,所有的顶点的入度都不为零,这样肯定形成了自环,自己理解的还不够,慢慢学习吧,另外这个题的输入特别坑,单个单个的字符输入会超时,需要每次输入一个字符串,才可以正常通过....晕死....


#include<stdio.h>
#include<string.h>
int n,x[2005][2005],ind[2005],cnt=0;
void tpsort()
{
    int i,j,k;
     for(i=0;i<n;++i)
    {
        for(j=0;j<n;++j)
        {
            if(ind[j]==0)
            {
                break;
            }
        }
        if(j>n-1)//程序内部出现所有的节点都不为零...
        {
            printf("Case #%d: Yes\n",++cnt);
            return;
        }
        ind[j]=-1;
        for(k=0;k<n;++k)
        {
            if(x[j][k])
            {
                --ind[k];
            }
        }
    }
    printf("Case #%d: No\n",++cnt);
}

int main()
{
    int t,i,j,b;
    char a,s[2005];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(x,0,sizeof(x));
        memset(ind,0,sizeof(ind));
        for(i=0;i<n;++i)
        {
            scanf("%s",s);
            for(j=0;s[j]!=0;++j)
            {
                if(s[j]=='1'&&!x[i][j])
                {
                    x[i][j]=1;
                    ++ind[j];
                }
            }
        }
        tpsort();
    }
    return 0; 
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值