Triangle LOVE 4324 (拓扑排序)

32 篇文章 0 订阅

Triangle LOVE

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 7
Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases. For each case, the first line contains one integer N (0 < N <= 2000). In the next N lines contain the adjacency matrix A of the relationship (without spaces). A[sub]i,j[/sub] = 1 means i-th people loves j-th people, otherwise A[sub]i,j[/sub] = 0. It is guaranteed that the given relationship is a tournament, that is, A[sub]i,i[/sub]= 0, A[sub]i,j[/sub] ≠ A[sub]j,i[/sub](1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”. Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
/*
题意::
		 有T组数据,每组数据第一行为N,接下来是N*N一个字符数组,若为‘1’表示喜欢
		 ‘0’表示不喜欢。如:: 
		5
		00100  //表示第1个人喜欢第3个。 
		10000  //第2个人喜欢第1个。 
		01001  //第3个人喜欢2和5. 
		11101  //第4人喜欢1,2,3,5 
		11000  //第5人喜欢1,2
		判断是否产生三角恋关系或多角恋关系(是否成环) 
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char map[2010][2010];
int in[2010];
int n;
int topo(int n)
{
	int i,j;
	for(j=0;j<n;j++)
	{
		int m=-1;
		for(i=0;i<n;i++)
		{
			if(in[i]==0)
			{
				in[i]--;
				m=i;
				break;
			}
		}
		if(m==-1)//如果成环,直接跳出循环 
			break;
		for(i=0;i<n;i++)//否则将他们逐个剔除 
		{
			if(map[m][i]=='1')
			{
				in[i]--;
				map[m][i]='0';
			}
		}
	}
	if(j<n)
		printf("Yes\n");
	else
		printf("No\n");
}
int main(){
	int t,s=1;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		int i,j;
		scanf("%d",&n);
		memset(in,0,sizeof(in));
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<n;j++)
			{
				if(map[i][j]=='1')
				{
					in[j]++;
				}
			}
		}
		printf("Case #%d: ",s++);
		topo(n);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值