poj 2506 Tiling【大数+递推】

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8290 Accepted: 3995

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251


大数处理,加上递推公式,

比较简单的可以发现第一项是 1 ,第二项是 3 ,然后从从第三项开始,第n项等于第n-1项加上第n-2项的二倍........




#include<stdio.h>
struct ds
{
	int y[10005];
	int len;
}x[355];
void db()
{
	int i,j;
	x[0].y[0]=x[1].y[0]=1;
	x[0].len=x[1].len=1;
	for(i=2;i<350;++i)
	{
		x[i].len=x[i-1].len;
		for(j=0;j<x[i].len;++j)
		{
			x[i].y[j]+=x[i-1].y[j]+2*x[i-2].y[j];
			if(x[i].y[j]>=10000)
			{
				
				x[i].y[j+1]+=x[i].y[j]/10000;
				x[i].y[j]%=10000;
			}
		}
		if(x[i].y[j]!=0)
		{
			++x[i].len;
		}
	}
}
int main()
{
	db();
	int n,i;
	while(~scanf("%d",&n))
	{
		printf("%d",x[n].y[x[n].len-1]);
		for(i=x[n].len-2;i>=0;--i)
		{
			printf("%04d",x[n].y[i]);
		}
		printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值