3172 Virtual Friends【并查集】

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6971    Accepted Submission(s): 1991


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

Sample Input
  
  
1 3 Fred Barney Barney Betty Betty Wilma
 

Sample Output
  
  
2 3 4


题目说的是,网上交友,朋友的朋友也是自己的朋友,问每次两个交了朋友之后,他们朋友圈里有多少人,

并查集处理比较顺,用上map 编号,比较简单就处理了.....但是这个题目的输入比较坑,很少见到这样的输入..........无限次指定次数的输入.........


#include<stdio.h>
#include<cstring>
#include<string>
#include<map>
#define max(a,b) (a>b?a:b)
using namespace std;
int per[100005],num[100005],maxn,k,cnt,n,x[100005];
void init()
{
	maxn=k=cnt=0;
	for(int i=0;i<100005;++i)
	{
		per[i]=i;
		num[i]=1;//全部赋值为 1 
	}
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	int i=x,j;
	while(i!=r)
	{
		j=per[i];per[i]=r;i=j;
	}
	return r;
}
void slove()
{
	init();
	map<string,int> map;
	char a[105],b[105];
	for(int i=0;i<n;++i)
	{
		scanf("%s%s",a,b);
		if(!map.count(a))
		{
			map[a]=k++;
		}
		if(!map.count(b))
		{
			map[b]=k++;
		}
		int u=map[a],v=map[b];
		int fx=find(u),fy=find(v);
		if(fx!=fy)
		{
			per[fy]=fx;
			num[fx]+=num[fy];//累加元素数量
			x[cnt++]=num[fx];//记录
		}
		else
		{
			x[cnt++]=num[fx];
		}
	}
	for(int i=0;i<cnt;++i)
	{
		printf("%d\n",x[i]);//输出
	}
}
int main()
{
	int t;
	while(~scanf("%d",&t))//!!!!注意输入格式!!!!!
	{
		while(t--)
		{
			scanf("%d",&n);
			slove();
		}
	}	
	return 0;
}


也是今天突然发现...原来不需要保存下来,直接就输出就可以了...

优化了一下,不过发现时间也没省多少啊.........

和上面的思路一样,也就不注释了....


#include<stdio.h>
#include<cstring>
#include<string>
#include<map>
#define max(a,b) (a>b?a:b)
using namespace std;
int per[100005],num[100005],maxn,k,cnt,n;
void init()
{
	maxn=k=cnt=0;
	for(int i=0;i<100005;++i)
	{
		per[i]=i;
		num[i]=1;
	}
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	int i=x,j;
	while(i!=r)
	{
		j=per[i];per[i]=r;i=j;
	}
	return r;
}
void slove()
{
	init();
	map<string,int> map;
	char a[105],b[105];
	for(int i=0;i<n;++i)
	{
		scanf("%s%s",a,b);
		if(!map.count(a))
		{
			map[a]=k++;
		}
		if(!map.count(b))
		{
			map[b]=k++;
		}
		int u=map[a],v=map[b];
		int fx=find(u),fy=find(v);
		if(fx!=fy)
		{
			per[fy]=fx;
			num[fx]+=num[fy];//数值累加
		}
		printf("%d\n",num[fx]);//直接输出就可以了.....
	}
}
int main()
{
	int t;
	while(~scanf("%d",&t))
	{
		while(t--)
		{
			scanf("%d",&n);
			slove();
		}
	}	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
虚拟机是一种解决方案,可以在一个操作系统中运行另一个操作系统,而应用程序对此毫无感知。虚拟机通常会占用较多的系统资源,启动和关闭也较慢。\[1\]而Docker是一种Linux容器技术的封装,提供了简单易用的容器使用接口。Docker将应用程序与其依赖打包在一个文件中,运行这个文件会生成一个虚拟容器,程序在这个容器中运行,就好像在真实的物理机上运行一样。\[2\]在Docker中启动Nginx时,需要使用CMD命令来指定容器的主进程,而不是使用service nginx start或systemctl start nginx命令。\[3\] 关于"virtual在线查毒"的问题,虚拟机本身并不具备查毒的功能。虚拟机只是提供了一个隔离的环境,可以在其中运行另一个操作系统。如果您需要在线查毒,您可以在虚拟机中安装一个杀毒软件,然后使用该软件进行查毒操作。请注意,虚拟机中的杀毒软件需要及时更新病毒库以保持最新的防护能力。 #### 引用[.reference_title] - *1* *2* *3* [【docker】docker虚拟容器的使用大全](https://blog.csdn.net/qq_41856814/article/details/104357623)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insert_down28v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值