并查集—Virtual Friends

**These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends’ friends, their friends’ friends’ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.
Your task is to observe the interactions on such a website and keep track of the size of each person’s network.
Assume that every friendship is mutual. If Fred is Barney’s friend, then Barney is also Fred’s friend.
Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
Sample Input
1
3
Fred Barney
Barney Betty
Betty Wilma
Sample Output
2
3
4**

网上交友,计算朋友间都有关系的最多人数
由于string类型的名字无法作为par数组的角标,因此用map为新出现的每一名字附上一个常量序号
又为了在集合上附上集合元素个数的量,因此为集合的根同样用map附上int量来表示

#include<cstdio>
#include<iostream>
#include<map>
#include<string>
using namespace std;
int par[100005];
int cnt;
map<string, int> num;
map<int, int> sum;
void init()
{
    for (int i = 0; i < 100005; i++)
    {
        par[i] = i;
        sum[i] = 1;
    }                //为节时,两者合并遍历
        cnt = 0;
    num.clear();    //达到所有元素"初始化"为零目的
}
int find(int i)
{
    /*if (i == par[i])            //与没有进行路径压缩的原代码(超时)对比
        return i;
    return find(par[i]);*/
    int r = i;
    while (r != par[r])
        r = par[r];
    int j = i;
    while (j != r)
    {
        int x = par[j];
        par[j] = r;
        j = x;
    }
    return r;
}
int unit(string a, string b)
{
    int apar = find(num[a]);
    int bpar = find(num[b]);
    if (apar != bpar)
    {
        par[apar] = bpar;
        sum[bpar] += sum[apar];
    }
    return sum[bpar];
}
int main()
{
    int T;
    string a, b;
    while (scanf("%d", &T) != EOF)      //没有!=EOF导致超时!?
    {
        while (T--)
        {
            init();
            int F;
            scanf("%d", &F);
            for (int i = 1; i <= F; i++)  //此处不能用while(F--)?
            {
                cin >> a >> b;               //不能用scanf("%s %s",&a,&b)输入string类a b
                if (!num[a])
                    num[a] = ++cnt;
                if (!num[b])
                    num[b] = ++cnt;
                cout << unit(a, b) << endl;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
虚拟机是一种解决方案,可以在一个操作系统中运行另一个操作系统,而应用程序对此毫无感知。虚拟机通常会占用较多的系统资源,启动和关闭也较慢。\[1\]而Docker是一种Linux容器技术的封装,提供了简单易用的容器使用接口。Docker将应用程序与其依赖打包在一个文件中,运行这个文件会生成一个虚拟容器,程序在这个容器中运行,就好像在真实的物理机上运行一样。\[2\]在Docker中启动Nginx时,需要使用CMD命令来指定容器的主进程,而不是使用service nginx start或systemctl start nginx命令。\[3\] 关于"virtual在线查毒"的问题,虚拟机本身并不具备查毒的功能。虚拟机只是提供了一个隔离的环境,可以在其中运行另一个操作系统。如果您需要在线查毒,您可以在虚拟机中安装一个杀毒软件,然后使用该软件进行查毒操作。请注意,虚拟机中的杀毒软件需要及时更新病毒库以保持最新的防护能力。 #### 引用[.reference_title] - *1* *2* *3* [【docker】docker虚拟容器的使用大全](https://blog.csdn.net/qq_41856814/article/details/104357623)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insert_down28v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值