Virtual Friends

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input

Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest. 
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output

2
3
4

做这个题的时候一开始以为很简单,然后就开始写,定义了一个结构体,然后写着写着就晕了,不知道怎么用了,然后才从网上开始查,发现要用map。map<string,int>  mp,相当于以string为下表,值是一个int,然后以后输出名字的时候,先判断一下这个mp[string]有没有值,有的话就证明前面输入过了,没有的话就给他赋一个之,按顺序一个一个赋。然后merge的时候每次都把那个人数就归上去,sum[t1]+=sum[t2]。然后输出就行了 

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <cmath>
#include <list>
#include <deque>
#include <queue>
#include <stack>
#include <map>
using namespace std;
const int maxn=150000;
int f[maxn];
int sum[maxn];
map<string,int> mp;
void init()
{
    for(int i=1;i<=maxn;i++)
    {
        f[i]=i;
        sum[i]=1;
    }
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else {
        f[v]=getf(f[v]);
        return f[v];
    }
}
int merge(string a,string b)
{
    int t1=getf(mp[a]),t2=getf(mp[b]);
    if(t1!=t2)
    {
        f[t2]=t1;
        sum[t1]+=sum[t2];
    }
    return sum[t1];
}
int main()
{
    int T;
    while(scanf("%d",&T)!=EOF){
    while(T--)
    {
        string s1="",s2="";
        int m,k=0;
        scanf("%d",&m);
        init();
        mp.clear();
        for(int i=1;i<=m;i++)
        {
            cin>>s1>>s2;
            if(!mp[s1])
            {
                mp[s1]=++k;
            }
            if(!mp[s2])
            {
                mp[s2]=++k;
            }
            cout<<merge(s1,s2)<<endl;
        }
    }
     }
    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值