Hdu 2604 Queuing【矩阵快速幂】

Queuing

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4062 Accepted Submission(s): 1803


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.

Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.

Input
Input a length L (0 <= L <= 10 6) and M.

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

Sample Input
  
  
3 8 4 7 4 8

Sample Output
  
  
6 2 1

本题的难点是排列组合找规律,找到递推公式,

f(0)=0,f(1)=2,f(2)=4,f(3)=6.f(4)=9;

当n>=5时,f(n)=f(n-1)+f(n-3)+f(n-4);

然后使用矩阵快速幂进行递推公式的加速递推.......

    | 1 0 1 1 |     | F[n-1] |      |   F[n]  |

    | 1 0 0 0 |  *  | F[n-2] | =   | F[n-1] |

    | 0 1 0 0 |     | F[n-3] |      | F[n-2] |

    | 0 0 1 0 |     | F[n-4] |      | F[n-3] |


#include<stdio.h>
#include<string.h>
int n,m;
struct matrix
{
	int mat[5][5];
	matrix operator * (const matrix &a)const
	{
		matrix tp;
		memset(tp.mat,0,sizeof(tp.mat));
		for(int i=0;i<4;++i)
		{
			for(int j=0;j<4;++j)
			{
				if(!mat[i][j])
				{
					continue;
				}
				for(int k=0;k<4;++k)
				{
					tp.mat[i][k]+=mat[i][j]*a.mat[j][k]%m;
					tp.mat[i][k]%=m;
				}
			}
		}
		return tp;
	}
}base,ans;
void init()
{
	memset(base.mat,0,sizeof(base.mat));
	memset(ans.mat,0,sizeof(ans.mat));
	for(int i=0;i<4;++i)
	{
		ans.mat[i][i]=1;
		base.mat[i+1][i]=base.mat[0][i]=1;
	}
	base.mat[0][1]=0;
}
int slove()
{
	int f[5]={0,2,4,6,9};
	if(n<=4)
	{
		return f[n]%m;
	}
	init();n-=4;
	while(n)
	{
		if(n&1)
		{
			ans=ans*base;
		}
		base=base*base;
		n>>=1;
	}
	int sum=0;
	for(int i=0;i<4;++i)
	{
		sum+=f[4-i]*ans.mat[0][i]%m;
		sum%=m;
	}
	return sum;
}
int main()
{
	//freopen("shuju.txt","r",stdin);
	while(~scanf("%d%d",&n,&m))
	{
		printf("%d\n",slove());
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值