POJ 3292 Semi-prime H-numbers【筛选素数变形】

33 篇文章 0 订阅

Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8562 Accepted: 3738

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62

Source


题意:

题目给出的是几种定义,把所有的4*n+1 形式的自然数定义为H-number,在此基础上定义如下:

H-primes 有以下性质的数:

1,,不为1;

2,除了1 和自身,不能写成其他两个数的乘积;


 H-semi-prime:

 能写成两个(可以相同)H-primes 的乘积


然后给出一个一个H-number,问这个区间内有多少个 H-semi-prime


题解:

首先想到的就是基于自然数的素数的筛选的方法,先标记上H-primes,然后再进行H-semi-prime 的筛选


一开始想的太天真了,想把两个 步骤放在一起,结果发现,根本行不通,筛选素数的那种方法,在没有筛选出所有的素数的时候,是不能使用进行对素数的判定的,因为还没筛选出来,其实筛选到n 的时候,只有1-n*n 的区域是完全确定的,其他区间都不能保证,因此只能选择用两次筛选进行控制了...也许是个人对素数的理解还不够,所以找不到更优化的方法,希望有路过的大神指点,谢谢!


步骤如下(打表):

1,模拟素数的筛选筛选出题目所定义的H-primes

2,进行遍历打表,筛选出所有的定义的H-semi-prime,并用数组实现循环累积


/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll maxn=1000001+5;
ll prime[maxn],num[maxn];
int main()
{
	for(ll i=5;i<maxn;i+=4)
	{
		if(!prime[i])
		{
			for(ll j=i*i;j<maxn;j+=4*i)
			{
				prime[j]=1;
			}
		}
	}
	for(ll i=5;i<maxn;i+=4)
	{
		num[i]+=num[i-4];
		if(!prime[i])
		{
			for(ll j=i*i;j<maxn;j+=4*i)
			{
				if(!prime[j/i])
				{
					num[j]=1;
				}
			}
		}
	}
	ll n;
	while(scanf("%lld",&n),n)
	{
		printf("%lld %lld\n",n,num[n]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值