poj 数论 Semi-prime H-numbers

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62
题意:H-number是4*n+1这样的数,如1,5,9,13... 。H-primes是这样一个H-number:它只能唯一分解成1*它本身,而不能表示为其他两个H-number的乘积。一个H-semi-prime是一个这样的H-number:它正好能表示成两个H-primes的乘积(除了1*它本身),这种表示法可以不唯一,但它不能表示为3个或者以上H-primes的乘积。现在给出一个数n,要求区间[1,n]内有多少个H-semi-prime。
思路:和求素数的筛选法相似,第一次筛选出H_primes。然后再枚举每两个H_primes构造出H_semi_prime,也可以用第二次筛选出H_semi_prim。
注意到X为H-semi-prime当且仅当X=i*j且i和j都为H-prime
而当t为H-prime时,当且仅当t有两个因子——1和t
且当t为H-semi-prime时,t必然是H-composites,所以,不用将H-composites和H-semi-prime分开处理
#include <iostream>
using namespace std;
int prime[1000010];
int hprime[1000010];
void solve()
{
    int i;
    for(int i=5;i<=1001;i+=4)
    {

        for(int j=i;i*j<=1000001;j+=4)
        {
            if(prime[i]==0&&prime[j]==0)
              prime[i*j]=1;
              else
              prime[i*j]=2;
        }
    }
    for(i=1;i<=1000001;i++)
    {
        if(prime[i]==1)
        hprime[i]=hprime[i-1]+1;
        else
        hprime[i]=hprime[i-1];
    }
}
int main()
{
    int h;
    solve();
    while(cin>>h)
    {

        if(h==0)
        break;
        cout<<h<<" "<<hprime[h]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值