Poj 2230 Watchcow【欧拉回路】

Watchcow
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 7050 Accepted: 3074 Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

Source


题意:

给出n个顶点m条边,让你设计一条路线,从1号点出发,经过每条路正反各一次,最终回到一号点,输出这条路线经过的顶点的顺序


题解:

相当于是把给出的一条无向边拆成两条反向的有向边,求欧拉回路的(本题保证一定有解),其实用邻接表建图的时候正好是建了正反两条边,相当于建立的就是有向图了,搜索的时候,直接对边进行搜索,标记,记录等.....


欧拉回路的条件:

无向图:图连通,所有的点的度都为偶数

有向图:图(强)连通,所有顶点的入度等于出度



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=10005;
int edgenum,head[maxn];
int ans[maxn*10],vis[maxn*10],cnt;
struct node
{
	int to,next;
}edge[maxn*10];
void init()
{
	edgenum=0;cnt=0;
	memset(head,-1,sizeof(head));
	memset(vis,0,sizeof(vis));
}
void add(int u,int v)
{
	node tp={v,head[u]};
	edge[edgenum]=tp;
	head[u]=edgenum++;
}
void dfs(int now)
{
	for(int i=head[now];i!=-1;i=edge[i].next)
	{
		if(!vis[i])
		{
			vis[i]=1;//标记当前边 
			//vis[i^1]=1; //标记反向边 
			dfs(edge[i].to);
		}
	}
	ans[cnt++]=now;
	//printf("%d\n",now);
}
int main()
{
	int n,m;
	//freopen("shuju.txt","r",stdin); 
	while(~scanf("%d%d",&n,&m))
	{
		init();
		for(int i=0;i<m;++i)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			add(a,b);add(b,a);
		}
		dfs(1);
		for(int i=0;i<cnt;++i)
		{
			printf("%d\n",ans[i]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值