POJ 2230 Watchcow

2016.12.31

【题目描述】
Bessie’s been appointed the new watch-cow for the farm. Every night, it’s her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she’s done.
If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she’s seen everything she needs to see. But since she isn’t, she wants to make sure she walks down each trail exactly twice. It’s also important that her two trips along each trail be in opposite directions, so that she doesn’t miss the same thing twice.
A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input
* Line 1: Two integers, N and M.
* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input
4 5
1 2
1 4
2 3
2 4
3 4

Sample Output
1
2
3
4
2
1
4
3
2
4
1

【解题思路】
求无向图每条边恰好经过两次,容易转化为有向图每条边经过一次

【代码实现】

#include <stdio.h>
#include <stack>
#include <iostream>

#define M 100005

using namespace std;

int cnt = 0;
int vis[M] = {0};
int v[M], ne[M], h[M];

stack <int> s;

void add(int ,int );
void euler(int );

int main(void)
{
    int i, j;
    int n, m, a, b;

    scanf("%d%d", &n, &m);
    for (i = 1; i <= m; ++i)
    {
        scanf("%d%d", &a, &b);
        add(a, b);
        add(b, a);
    }

    euler(1);

    printf("1\n");
    while (s.size())
    {
        printf("%d\n", s.top());
        s.pop();
    }

    return 0;
}

void euler(int k)
{
    int t;

    for (t = h[k]; t; t = ne[t])
        if (!vis[t])
        {
            vis[t] = 1;
            euler(v[t]);
            s.push(v[t]);
        }
}

void add(int x, int y)
{
    v[++cnt] = y;
    ne[cnt] = h[x];
    h[x] = cnt;
}

【心得体会】
学会问题的转化

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值