Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
在这里插入图片描述
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

题目大意,构造出一颗二叉排序树,然后输出二叉排序树的层序遍历。
每个输入文件包含一个测试用例。对于每种情况,第一行给出一个正整数N (≤100),这是树中节点的总数。接下来的N行各包含一个节点的左右子节点,格式为left_index right_index,前提是节点编号从0到N-1,0始终是根。如果缺少一个子指针,那么1将代表空的子指针。最后,最后一行给出了N个不同的整数键。

解题思路:
由于二叉树的中序遍历可以使得各节点的data值有序输出,因此在这个题在输入各个节点的数据之后,先构造出树的形状,然后中序遍历这颗二叉树,存储好该二叉排序树的中序遍历序列,最后再按升序赋上各节点的data值,此时一颗二叉排序树便已经构造好,最后层序遍历,输出层序遍历序列即可。

#include<bits/stdc++.h>
using namespace std;
int n;
struct Node
{
    int data;
    int lchild, rchild;
}node[120];
int mp[120] = {0}, cnt = 0;
void build_tree() {
    int a, b;
    for(int i = 0; i < n; i++) {
        scanf("%d%d", &a, &b);
        node[i].lchild = a;
        node[i].rchild = b;
    }
}
void inorder(int k) {//中序遍历
    if(k == -1) return;
    inorder(node[k].lchild);
    mp[cnt++] = k;
    inorder(node[k].rchild);
}
void levelorder(int sum) {//层序遍历
    queue<Node>q;
    q.push(node[0]);//根节点入队
    while (!q.empty()) {
        Node qu = q.front();
        q.pop();
        if(sum < n - 1)printf("%d ", qu.data);
        else printf("%d", qu.data);
        if(qu.lchild != -1) q.push(node[qu.lchild]);
        if(qu.rchild != -1) q.push(node[qu.rchild]);
        sum++;
    }
}
int main() {
    scanf("%d", &n);
    build_tree();
    inorder(0);
    // for(int i = 0; i < n; i++) cout << mp[i] << " ";
    // cout << endl;
    int num[n+1];
    for(int i = 0; i < n; i++) scanf("%d", &num[i]);
    sort(num, num + n);
    for(int i = 0; i < n; i++) {
        node[mp[i]].data = num[i];
    }
    levelorder(0);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值