hdu 1159(最长公共子序列)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1159

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23712    Accepted Submission(s): 10466


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 

Source
 

题意:给定两个字符串,求最长公共子序列的长度;s1[]存储第一个字符串,s2[]存储第二个字符串;

思路:简单dp,(1)首先明确dp所要表示的含义,dp[i][j]表示第一个字符串前i个字符,与后一个字符串的前j个字符匹配的最长公共子序列的长度值;

                              (2) 递推明确状态转移方程:  if(s1[i]==s2[j])dp[i][j]=dp[i-1][j-1]+1;

                                                                                    else dp[i][j]=max(dp[i][j-1],dp[i-1][j]);

                             

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
const int maxn=1000;
using namespace std;
int dp[maxn][maxn];
char s1[maxn],s2[maxn];

int main()
{
        while(scanf("%s%s",s1,s2)!=EOF)
        {
           int n=strlen(s1);    //第一个字符串的长度
           int m=strlen(s2);    //第二个字符串的长度
           memset(dp,0,sizeof(dp));
           char *A=s1,*B=s2;
           
           if(n>m)           //dp过程开始前得保证字符串长度小的放前~~
            {
             swap(n,m);
             swap(A,B);
            }

           for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            {
                if(A[i-1]==B[j-1])
                    {
                        dp[i][j]=dp[i-1][j-1]+1;

                        //cout<<i<<" "<<j<<" "<<dp[i][j]<<endl;
                    }
                else
                    {
                        dp[i][j]=max(dp[i][j-1],dp[i-1][j]);

                        //cout<<i<<" "<<j<<" "<<dp[i][j]<<endl;
                    }
            }

           cout<<dp[n][m]<<endl;
        }
        return 0;
}


(2) 用滚动数组优化~因为最终我只要知道 dp[n][m] 的值即可,前面的可以覆盖~所以可以用滚动数组来节省空间;

优化代码:

    

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
const int maxn=1000;
using namespace std;
int dp[2][maxn];
char s1[maxn],s2[maxn];

int main()
{
        while(scanf("%s%s",s1,s2)!=EOF)
        {
           int n=strlen(s1);    //第一个字符串的长度
           int m=strlen(s2);    //第二个字符串的长度
           memset(dp,0,sizeof(dp));
           char *A=s1,*B=s2;

           if(n>m)           //dp过程开始前得保证字符串长度小的放前~~
            {
             swap(n,m);
             swap(A,B);
            }

           for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            {
                if(A[i-1]==B[j-1])
                    {
                        dp[i&1][j]=dp[(i-1)&1][j-1]+1;

                        //cout<<i<<" "<<j<<" "<<dp[i][j]<<endl;
                    }
                else
                    {
                        dp[i&1][j]=max(dp[i&1][j-1],dp[(i-1)&1][j]);

                        //cout<<i<<" "<<j<<" "<<dp[i][j]<<endl;
                    }
            }

           cout<<dp[n&1][m]<<endl;
        }
        return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值