hdu 5015(矩阵快速幂)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5015

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 823    Accepted Submission(s): 493


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).
 

Output
For each case, output a n,m mod 10000007.
 

Sample Input
  
  
1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output
  
  
234 2799 72937
Hint
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5041  5040  5039  5038  5037 
思路:矩阵快速幂,由第一列推出剩下的列~有点得注意,要用I64d,如果用int 会wrong~~~可以从题目给的时间5000ms和题目给的数据看很出来~

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
const int mod=10000007;
typedef long long ll;
using namespace std;
int a[12];

struct matrix
{
 ll f[12][12];
};
//两矩阵相乘;
matrix mul(matrix a,matrix b)
{
  matrix c;
  memset(c.f,0,sizeof(c.f));
  for(int i=0;i<12;i++)
   for(int j=0;j<12;j++)
    for(int k=0;k<12;k++)
    {
     c.f[i][j]+=a.f[i][k]*b.f[k][j]%mod;  //再次提醒自己  是乘不是加,之所以要mod 是因为两者相乘会溢出
     c.f[i][j]%=mod;
    }
  return c;
}
matrix pow_mod(matrix a,int b)
{
  matrix s;
  memset(s.f,0,sizeof(s.f));
  for(int i=0;i<12;i++)
    s.f[i][i]=1;
  while(b)
  {
    if(b&1)
    {
     s=mul(s,a);
    }
    b=b/2;
    a=mul(a,a);
  }
  return s;
}
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
      matrix e;
      memset(e.f,0,sizeof(e.f));
      for(int i=1;i<11;i++)
        for(int j=0;j<=i;j++)
          e.f[i][j]=1;
      e.f[0][0]=10; e.f[0][11]=1,e.f[11][11]=1;

      memset(a,0,sizeof(a));
      for(int i=1;i<=n;i++)cin>>a[i];
      a[0]=233,a[11]=3;
      e=pow_mod(e,m);
      ll sum=0;
      for(int i=0;i<12;i++)
      {
       sum=(sum+(e.f[n][i]*a[i]))%mod;
      }
      printf("%I64d\n",sum%mod);
   }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值