ACdream 1431(爆搜)

题目链接:http://acdream.info/problem?pid=1431

Sum vs Product

Time Limit: 4000/2000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others)
Problem Description

      Peter has just learned mathematics. He learned how to add, and how to multiply. The fact that 2 + 2 = 2 × 2 has amazed him greatly. Now he wants find more such examples. Peters calls a collection of numbers beautiful if the product of the numbers in it is equal to their sum. 

      For example, the collections {2, 2}, {5}, {1, 2, 3} are beautiful, but {2, 3} is not. 

      Given n, Peter wants to find the number of beautiful collections with n numbers. Help him!

Input
      The first line of the input file contains n (2 ≤ n ≤ 500)
Output
      Output one number — the number of the beautiful collections with n numbers.
Sample Input
2
5
Sample Output
1
3
Hint
The collections in the last example are: {1, 1, 1, 2, 5}, {1, 1, 1, 3, 3} and {1, 1, 2, 2, 2}.
Source
Andrew Stankevich Contest 23
Manager
思路:比赛时想了好久,还打表找出10以内的所以解,但是最后还是没有做出来;

看了题解有所悟,暴力搜索;

直接上代码:

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <cstdio>
#include <cmath>
using namespace std;
int n,cnt;

void dfs(int now,int N,int sum,int mul)
{

 if(now==n+1)
 {
   if(sum==mul)cnt++;
   return;
 }

 for(int i=1;i<=N;i++)
 {
   if(sum+i+n-now<mul*i)return;
   dfs(now+1,i,sum+i,mul*i);
 }

}

void solve()
{
 cnt=0;
 dfs(1,n,0,1); //从第一层开始搜
 printf("%d\n",cnt);
}

int main()
{

  while(scanf("%d",&n)!=EOF)
  {

    solve();
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值