hdu 4815(dp)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=4815

Little Tiger vs. Deep Monkey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 788    Accepted Submission(s): 293


Problem Description
A crowd of little animals is visiting a mysterious laboratory – The Deep Lab of SYSU.

“Are you surprised by the STS (speech to speech) technology of Microsoft Research and the cat face recognition project of Google and academia? Are you curious about what technology is behind those fantastic demos?” asks the director of the Deep Lab. “Deep learning, deep learning!” Little Tiger raises his hand briskly. “Yes, clever boy, that’s deep learning (深度学习/深度神经网络)”, says the director. “However, they are only ‘a piece of cake’. I won’t tell you a top secret that our lab has invented a Deep Monkey (深猴) with more advanced technology. And that guy is as smart as human!”

“Nani ?!” Little Tiger doubts about that as he is the smartest kid in his kindergarten; even so, he is not as smart as human, “how can a monkey be smarter than me? I will challenge him.”

To verify their research achievement, the researchers of the Deep Lab are going to host an intelligence test for Little Tiger and Deep Monkey.

The test is composed of N binary choice questions. And different questions may have different scores according to their difficulties. One can get the corresponding score for a question if he chooses the correct answer; otherwise, he gets nothing. The overall score is counted as the sum of scores one gets from each question. The one with a larger overall score wins; tie happens when they get the same score.

Little Tiger assumes that Deep Monkey will choose the answer randomly as he doesn’t believe the monkey is smart. Now, Little Tiger is wondering “what score should I get at least so that I will not lose in the contest with probability of at least P? ”. As little tiger is a really smart guy, he can evaluate the answer quickly.

You, Deep Monkey, can you work it out? Show your power!
 

Input
The first line of input contains a single integer T (1 ≤ T ≤ 10) indicating the number of test cases. Then T test cases follow.

Each test case is composed of two lines. The first line has two numbers N and P separated by a blank. N is an integer, satisfying 1 ≤ N ≤ 40. P is a floating number with at most 3 digits after the decimal point, and is in the range of [0, 1]. The second line has N numbers separated by blanks, which are the scores of each question. The score of each questions is an integer and in the range of [1, 1000]
 

Output
For each test case, output only a single line with the answer.
 

Sample Input
  
  
1 3 0.5 1 2 3
 

Sample Output
  
  
3
 

Source
思路:(1)刚开始就想着直接暴力枚举,然后再遍历一遍就行了,但是一看2^n很大,所以就不行了

             (2)可以考虑dp(其实是01背包问题),我用dp[i][j]表示做第i道题的时候总得分为j的概率,然后状态转移方程式:dp[i][j]=dp[i-1][j]*0.5+dp[i][k]*0.5(其中k+a[i]==j)

但是这样得三层循环,我写了好几遍都TLE;最后改为两层循环过了,好久没写背包问题了,感觉自己好弱~

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
double dp[44][44000];
int a[44];
int b[44];

int main()
{
    int T,n;
    double p;
    cin>>T;
    while(T--)
    {
      scanf("%d%lf",&n,&p);
      memset(dp,0,sizeof(dp));
      memset(a,0,sizeof(a));
      memset(b,0,sizeof(b));

      for(int i=1;i<=n;i++)
      {
        scanf("%d",&a[i]);
        b[i]=b[i-1]+a[i];
      }

     //dp处理
      dp[1][0]=0.5;
      dp[1][a[1]]=0.5;

      for(int i=1;i<=n;i++)
        for(int j=0;j<=b[i];j++)
        {
          if(dp[i][j]>0)
          {
            dp[i+1][j+a[i+1]]+=dp[i][j]*0.5;
            dp[i+1][j]+=dp[i][j]*0.5;
          }
        }

     //遍历一遍找出最小值


     int score=0;
     double sum=0.0;
     
     for(int i=0;i<=b[n];i++)
     {
      sum+=dp[n][i];
      if(sum>=p)
      {
       score=i;
       break;
      }
     }
     printf("%d\n",score);

    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值