POJ1426——Find The Multiple (BFS)

2 篇文章 0 订阅
1 篇文章 0 订阅
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
 
10
100100100100100100
111111111111111111

这道题啊~
题目大意就是:告诉你一个数n,要求你找到你个只有0和1组成的数,可以整除n;

解题方法: BFS+同余模定理

BFS:宽度搜索,可近的先来

同余模定理

(a*b)%n = (a%n *b%n)%n

(a+b)%n = (a%n +b%n)%n

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

int mod[600000];

int main()
{
    int n,i;
    while(cin>>n,n)    ///按n=6举例
    {
        mod[1]=1;       ///因为第一个数必须是1
        for(i=2;mod[i-1]!=0;i++)    ///循环中的 mod[i-1]!=0,是之前没有想到运用的
        {
            mod[i]=(mod[i/2]*10+i%2)%n;///循环次数,很强大的功能,(i/x,就能循环x次)
                                       ///mod[2]=(mod[1]*10+0)%6;
                                       ///mod[3]=(mod[1]*10+1)%6;
                                       ///mod[4]=(mod[2]*10+0)%6;
                                       ///mod[5]=(mod[2]*10+1)%6;
                                       ///以此类推,mod[i/2]*10+i%2模拟了BFS的双入口搜索  
                                       ///当i为偶数时 +0,即取当前位数字为0。为奇数时 则+1,即取当前位数字为1  
        }
        i--; ///之前i=15,所以i要减1,变成14,即循环次数,14次。
        int k=0;
        while(i)
        {
            mod[k++]=i%2;   ///把*10操作转化为%2操作,逆向求倍数的每一位数字  
            i/=2;           ///mod[1]=0; i=7
                            ///mod[2]=1; i=3
                            ///mod[3]=1; i=1
                            ///mod[4]=1; i=0
                            ///退出
        }
        while(k)
            cout<<mod[--k]; ///倒序输出  
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值