HDU - 5832 A water problem(大整数取模)

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3072    Accepted Submission(s): 1113


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is  73  days in Xixi a year and  137  days in Haha a year. 

Now you know the days  N  after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 

Input
There are several test cases(about  5  huge test cases).

For each test, we have a line with an only integer  N(0N) , the length of  N  is up to  10000000 .
 

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 

Sample Input
  
  
10001 0 333
 

Sample Output
  
  
Case #1: YES Case #2: YES Case #3: NO

题意:输入一个数,判断能不能整除73,和137。n的长度很长,只能用字符串。

解决:能整除两个个数,就是能整除10001(73*137)。然后就是求n能否整除10001,紫书314页介绍了大整数取模的算法,直接拿来用了。

细节:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstdlib>
#include<sstream>
#include<deque>
#include<stack>
#include<set>
#include<map>
using namespace std;

int n, m, k;
char ch[maxn];
int main(){
    int kase = 0;
    while(~scanf("%s", ch)){
        int x = 10001;
        int len = strlen(ch);
        int ans = 0;
        for(int i = 0; i < len; ++i){
            ans = (int)(((ll)ans * 10 + ch[i] - '0') % x);
        }
//        printf("%d***\n", ans);
        if(!ans) printf("Case #%d: YES\n", ++kase);
        else printf("Case #%d: NO\n", ++kase);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值