【SSL1341——POJ3041】Asteroids

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

题目大意

题目给出一个矩阵,上面有敌人,每个子弹可以打出一横行或者一竖行,问最少用多少子弹消灭都有敌人,如:
X.X
.X.
.X.
x表示敌人,显然用两个子弹就可以解决所有敌人。

思路:

这题粗略一看大概是道最小顶点覆盖问题,可我们考虑怎样建图

X.X 
.X. 
.X. 

我们考虑第一行,发现如果在这一行打一颗子弹,它会把1,3的敌人消灭
二,三行同理
考虑第一列,在这一列打一颗子弹,它会把1的敌人消灭
其实我们发现就是把当前行给当前敌人所在列连边就行

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<cstring>
using namespace std;

int n, m, s, tot, head[110];
int cover[110], link[110]; 
struct node{
	int to, next;
}b[10010];

void add(int x, int y)
{
	b[++tot]=(node){y, head[x]};
	head[x]=tot;
}

bool find(int x)
{
	for(int i=head[x]; i; i=b[i].next)
	{
		int y=b[i].to;
		if(!cover[y])
		{
			cover[y]=1;
			int q=link[y];
			link[y]=x;
			if(q==0||find(q))
				return true;
			link[y]=q;
		}
	} 
	return false;
}
int main(){
	scanf("%d%d", &n, &s);
	for(int i=1; i<=s; i++)
	{
		int x, y;
		scanf("%d%d", &x, &y);
		add(x, y);
	}
	for(int i=1; i<=n; i++)
	{
		memset(cover, 0, sizeof(cover));
		find(i);
	}
	int ans=0;
	for(int i=1; i<=n; i++)
		if(link[i]!=0)
			ans++;
	printf("%d", ans);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值