F - Anniversary party HDU - 1520 Anniversary party 树形DP

F - Anniversary party HDU - 1520 

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings. 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

Output

Output should contain the maximal sum of guests' ratings. 

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意: n个人,编号1~n,再输入每个人的权值var,然后输入 (子节点编号  父节点编号),输入0 0代表节点关系的输入结束,求选哪些点能使总权值最大(选了子节点就不能选父节点)

思路:dp[i][0]代表不选i节点的最大总权值,dp[i][1]代表选;

           则:dp[i][1]=sum(dp[ i 的子节点 ][0])+var[i];(选i时不能选i的子节点)

                  dp[i][0]=sum(max(dp[ i 的子节点 ][0],dp[ i 的子节点 ][1]));(不选i时,i的子节点可选可不选,取最大值)

PS:sum代表求和

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#define fora(i,a,b) for(i=a;i<b;i++)
#define fors(i,a,b) for(i=a;i>b;i--)
#define fora2(i,a,b) for(i=a;i<=b;i++)
#define fors2(i,a,b) for(i=a;i>=b;i--)
#define PI acos(-1.0)
#define eps 1e-6
#define INF 0x3f3f3f3f

typedef long long LL;
typedef long long LD;
using namespace std;
const int maxn=6000+11;
const int mod=10056;
int n;
struct node
{
    int var;//权值
    int fa;//父节点
}a[maxn];
int dp[maxn][2];
set<int>son;//存叶子节点
set<int>father;//根,也许有多棵树,英文不太好,只能看大概题意,以防万一
queue<int>q;//当前页子节点,每算完一个节点,删除一个节点
int in[maxn];//节点的入度
int ans=-1111111;
void read()
{
    ans=-1111111;
    father.clear();
    son.clear();
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i].var);
        dp[i][1]=a[i].var;
        dp[i][0]=0;
        in[i]=0;
        a[i].fa=i;
        ans=max(a[i].var,ans);
        son.insert(i);
    }
    int f,s;
    while(~scanf("%d%d",&s,&f)&&(s+f))
    {
        a[s].fa=f;
        in[f]++;
        son.erase(f);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        read();
        for(set<int>::iterator it=son.begin();it!=son.end();it++)
        {
            q.push(*it);
        }
        while(!q.empty())
        {
            int t=q.front();
            q.pop();
            int f=a[t].fa;
            if(f!=t)
            {
                in[f]--;
                dp[f][1]+=dp[t][0];
                dp[f][0]+=max(dp[t][1],dp[t][0]);
                if(in[f]==0){q.push(f);}
                ans=max(max(ans,dp[f][1]),dp[f][0]);
            }
            else
                father.insert(f);
        }
        int sum=0;
        for(set<int>::iterator it=father.begin();it!=father.end();it++)//可能有多棵树
        {
            sum=max(sum,max(sum+dp[*it][1],sum+dp[*it][0]));
        }
        ans=max(ans,sum);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值