2015年第十四周oj刷题:

Problem J: C++习题 复数类--重载运算符+

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 871   Solved: 577
[ Submit][ Status][ Web Board]

Description

定义一个复数类Complex,重载运算符“+”,使之能用于复数的加法运算。将运算符函数重载为非成员、非友元的普通函数。编写程序,求两个复数之和。

Input

两个复数

Output

复数之和

Sample Input

3 4
5 -10

Sample Output

(8.00,-6.00i)
#include <iostream>

#include <iomanip>

using namespace std;

class Complex

{

public:

    Complex();

    Complex(double r,double i);

    double get_real();

    double get_imag();

    void display();

private:

    double real;

    double imag;

};
double Complex::get_imag()
{
    return imag;
}
double Complex::get_real()
{
    return real;
}
Complex::Complex(double r,double i)
{
    real=r;
    imag=i;
}
Complex operator+(Complex &c1,Complex &c2)
{
    return Complex(c1.get_real()+c2.get_real(),c1.get_imag()+c2.get_imag());
}
void Complex::display()
{
    cout<<"("<<real<<","<<imag<<"i)";
}
int main()

{

    double real,imag;

    cin>>real>>imag;

    Complex c1(real,imag);

    cin>>real>>imag;

    Complex c2(real,imag);

    Complex c3=c1+c2;

    cout<<setiosflags(ios::fixed);

    cout<<setprecision(2);

    c3.display();

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值