[POJ1840]-Eqs

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 15321 Accepted: 7522

Description

Consider equations having the following form: 
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
题目描述:
给你一个公式a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 ,并且给出a1~a5的数据,让你求得满足方程解的个数
给出a1~a5,x1~x5的范围都是[-50,50];
解题思路:
直接HASH+折半枚举,但是这里有要注意的地方,由于这里HASH数组要开的很大,所以要注意一个内存问题
刚开始没注意内存以为不会爆炸,结果开int数组开到10M++了,把我自己都吓一跳,直接内存超限,后来改用short交上去却是RE,
需要优化。总的来说还是比较水的.....
//head.h
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <cmath>
#include <ctime>
#include <algorithm>
#include <string>
#include <memory>
#include <string>
#include <list>
#include <queue>
#include <deque>
#include <vector>
#include <stack>
#include <utility>
#include <set>
#include <map>
#include <iterator>
#include <fstream>
#define LOCAL

#ifndef LOCAL
#include "head.h"
#endif
using namespace std;
const int N=20000000;//别开得太大,我这样已经很大了,都5M多了
int a[5];
short HASH[N*2];
int main()
{
	// memset(HASH,0,sizeof(HASH));
	// freopen("data1840.in","r",stdin);
	for(int i = 0;i < 5;++ i)
	{
		scanf("%d",a+i);
	}
	for(int i = -50;i <= 50;++ i)
	{
		if(i!=0)
			for(int j = -50;j <= 50;++ j)
				if(j!=0)
					for(int k = -50;k <= 50;++ k)
						if(k!=0)
						{
							int tmp = a[0]*i*i*i+a[1]*j*j*j+a[2]*k*k*k;
							HASH[N-tmp]++;
						}
	}
	int res=0;
	for(int i = -50;i <= 50;++ i)
	{
		if(i!=0)
			for(int j = -50;j <= 50;++ j)
				if(j!=0)
				{
					int tmp = a[3]*i*i*i+a[4]*j*j*j;
					if(tmp<=N&&tmp>=-N)//必须要判断不然会RE
						res+=HASH[tmp+N];
				}

	}
	printf("%d\n",res);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值