ZOJ 3203 Light Bulb

E - Light Bulb
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%lld & %llu

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000



数学题,推公式,求区间最值即可。


#include <stdio.h>
#include <math.h>
int main()
{
        int t;
        scanf("%d",&t);
        while(t--)
        {
                double D,H,h;
                scanf("%lf%lf%lf",&H,&h,&D);
                double temp=sqrt((H-h)*D);
                double temp2=(H-h)*D/H;
                double ans;
                if(temp>=D)
                        ans=h;
                else if(temp<temp2)
                        ans=h*D/H;
                else
                        ans=D+H-temp-(H-h)*D/temp;
                printf("%.3lf\n",ans);
        }
        return 0;
}


做完在网上搜了一下发现,原来是道三分。。。。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值