HDU 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39784    Accepted Submission(s): 17541


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 


题目大意:给定一个数字n,判断由1->n组成的圆环是否是素数圆环(每个数和周围的数字的和为素数)

#include <stdio.h>
#include <algorithm>
#include <string.h>
int a[30],b[30];
int n,num;
bool prime(int nn)
{
    if(nn==1)
        return 0;
    for(int i=2; i<nn; i++)
        if(nn%i==0)
        {
            return 0;
        }
    return 1;
}
void dfs(int s)
{
    if(s>n&&prime(a[n]+a[1]))
    {
        for(int i=1; i<n; i++)
        {
            printf("%d ",a[i]);
        }
        printf("%d\n",a[n]);
    }
    else
    {
        for (int i=2; i<=n; i++)
        {
            if(!b[i]&&prime(i+a[s-1]))
            {
                    b[i]=-1;
                    a[s]=i;
                    dfs(s+1);
                    b[i]=0;
            }
        }
    }
}
int main()
{
    num=0;
    while (scanf("%d",&n)!=EOF)
    {
        num++;
        printf("Case %d:\n",num);
        a[1]=1;
        b[1]=1;
        memset(b,0,sizeof(b));
        dfs(2);
        printf("\n");
    }
    return 0;
}


一开始把i定义为全局变量。。。。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

会飞的Anthony

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值