ZOJ 146 - The 13th Zhejiang Provincial Collegiate Programming Contest - C Defuse the Bomb

Defuse the Bomb

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The bomb is about to explode! Please defuse it as soon as possible!

There is a display showing a number from 1 to 4 on the bomb. Besides this, there are 4 buttons under the display. Each button is labeled by a number from 1 to 4. The numbers on the buttons are always distinct.

There are 5 defusing stages in total. Pressing the correct button can progress the bomb to the next defusing stage. The number on the display and the number on each button may be different in different stages. The bomb will be defused only when all 5 defusing stages get passed. Pressing the incorrect button will cause the bomb to explode immediately. Be careful!

Here is the detailed bomb defusing manual. Button positions are ordered from left to right.

Stage 1:

  • If the display is 1, press the button in the second position.
  • If the display is 2, press the button in the second position.
  • If the display is 3, press the button in the third position.
  • If the display is 4, press the button in the fourth position.

Stage 2:

  • If the display is 1, press the button labeled "4".
  • If the display is 2, press the button in the same position as you pressed in stage 1.
  • If the display is 3, press the button in the first position.
  • If the display is 4, press the button in the same position as you pressed in stage 1.

Stage 3:

  • If the display is 1, press the button with the same label you pressed in stage 2.
  • If the display is 2, press the button with the same label you pressed in stage 1.
  • If the display is 3, press the button in the third position.
  • If the display is 4, press the button labeled "4".

Stage 4:

  • If the display is 1, press the button in the same position as you pressed in stage 1.
  • If the display is 2, press the button in the first position.
  • If the display is 3, press the button in the same position as you pressed in stage 2.
  • If the display is 4, press the button in the same position as you pressed in stage 2.

Stage 5:

  • If the display is 1, press the button with the same label you pressed in stage 1.
  • If the display is 2, press the button with the same label you pressed in stage 2.
  • If the display is 3, press the button with the same label you pressed in stage 4.
  • If the display is 4, press the button with the same label you pressed in stage 3.
Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

There are 5 lines. Each line contains 5 integers DB1B2B3B4 indicating the number on the display and the numbers on the buttons respectively. The i-th line correspond to thei-th stage.

Output

For each test case, output 5 lines. The i-th line contains two integers indicating the position and the label of the correct button for the i-th stage.

Sample Input
1
4 2 1 3 4
2 2 4 3 1
4 3 1 4 2
4 3 4 2 1
2 3 1 2 4
Sample Output
4 4
4 1
3 4
4 1
2 1
Hint

Keep talking with your teammates and nobody explodes!


渣渣只会做简单模拟。。。



#include <iostream>
using namespace std;
int main()
{
    int t,a[5][5],i,j,b[5];
    cin>>t;
    while(t--)
    {
        for(i=0; i<5; i++)
            for(j=0; j<5; j++)
            {
                cin>>a[i][j];
            }
        if(a[0][0]==1||a[0][0]==2)
        {
            cout<<"2"<<" "<<a[0][2]<<endl;
            b[0]=2;
        }
        else if(a[0][0]==3)
        {
            cout<<"3"<<" "<<a[0][3]<<endl;
            b[0]=3;
        }
        else
        {
            cout<<"4"<<" "<<a[0][4]<<endl;
            b[0]=4;
        }
        if(a[1][0]==1)
        {
            for(i=1; i<5; i++)
                if(a[1][i]==4)
                {
                    cout<<i<<" "<<"4"<<endl;
                    b[1]=i;
                }
        }
        else if(a[1][0]==2||a[1][0]==4)
        {
            cout<<b[0]<<" "<<a[1][b[0]]<<endl;
            b[1]=b[0];
        }
        else
        {
            cout<<"1"<<" "<<a[1][1]<<endl;
            b[1]=1;
        }
        if(a[2][0]==1)
        {
            for(i=1; i<5; i++)
                if(a[2][i]==a[1][b[1]])
                {
                    cout<<i<<" "<<a[2][i]<<endl;
                    b[2]=i;
                }
        }
        else if(a[2][0]==2)
        {
            for(i=1; i<5; i++)
                if(a[2][i]==a[0][b[0]])
                {
                    cout<<i<<" "<<a[2][i]<<endl;
                    b[2]=i;
                }
        }
        else if(a[2][0]==3)
        {
            cout<<"3 "<<a[2][3]<<endl;
            b[2]=3;
        }
        else
        {
            for(i=1; i<5; i++)
                if(a[2][i]==4)
                {
                    cout<<i<<" "<<"4"<<endl;
                    b[2]=i;
                }
        }
        if(a[3][0]==1)
        {
            cout<<b[0]<<" "<<a[3][b[0]]<<endl;
            b[3]=b[0];
        }
        else if(a[3][0]==2)
        {
            cout<<"1 "<<a[3][1]<<endl;
            b[3]=1;
        }
        else
        {
            cout<<b[1]<<" "<<a[3][b[1]]<<endl;
            b[3]=b[1];
        }
        if(a[4][0]==1)
        {
            for(i=1; i<5; i++)
                if(a[4][i]==a[0][b[0]])
                {
                    cout<<i<<" "<<a[4][i]<<endl;
                    b[4]=i;
                }
        }
        else if(a[4][0]==2)
        {
            for(i=1; i<5; i++)
                if(a[4][i]==a[1][b[1]])
                {
                    cout<<i<<" "<<a[4][i]<<endl;
                    b[4]=i;
                }
        }
        else if(a[4][0]==3)
        {
            for(i=1; i<5; i++)
                if(a[4][i]==a[3][b[3]])
                {
                    cout<<i<<" "<<a[4][i]<<endl;
                    b[4]=i;
                }
        }
        else
        {
            for(i=1; i<5; i++)
                if(a[4][i]==a[2][b[2]])
                {
                    cout<<i<<" "<<a[4][i]<<endl;
                    b[4]=i;
                }
        }
    }
    return 0;
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值