Coin Change

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19678    Accepted Submission(s): 6879


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
  
  
11 26
 

Sample Output
  
  
4 13
 

Author
Lily
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1171  1398  1085  1028  2152 
 
#include<stdio.h>
#include<string.h>
#include<math.h>
//#include<stdlib.h>
#include<algorithm>
#include<iostream>
const int maxn=410;
int b[6]= {1,5,10,25,50};
int main() {
    int i,j,k,g,f;
    int n;
    while(scanf("%d",&n)!=EOF) {
        int ans=0,t,m=100;
        for(i=0; i<=n; i++) {
            for(j=0; j<=(n-i*b[0])/b[1]; j++) {
                for(k=0; k<=(n-i*b[0]-j*b[1])/b[2]; k++) {
                    for(g=0; g<=(n-i*b[0]-j*b[1]-k*b[2])/b[3]; g++) {
                        for(f=0; f<=(n-i*b[0]-j*b[1]-k*b[2]-g*b[3])/b[4]; f++) {
                            if(n-i*b[0]-j*b[1]-k*b[2]-g*b[3]-f*b[4]==0&&(i+j+k+g+f)<=m)
                                ans++;
                        }
                    }
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值