acm 2 1001 二分法

1.1001

2.

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
  
  
2<br>100<br>-4<br>

Sample Output
  
  
1.6152<br>No solution!<br>
3.基本题意,对于题中方程,输入已知的y值,计算出x的值

4.本题中方程以确定,y值是给定的值,求x,并且对x设定了范围限制,是基本的二分思想,逐步缩小范围,直到解出或无解

5.

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
using namespace std;
double f(double x)
{
    double l;
    l=8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
    return l;
}
int main()
{
    double n,i,k,z,l,e;
    double t,t1,t2;
    double x,y;
    cin>>n;
    while(n--)
    {
        cin>>y;
        if(f(0)>y||f(100)<y)
        {
            cout<<"No solution!"<<endl;
            continue;
        }
        else
        {
            t1=0;
            t2=100;
            while(t2-t1>0.00000001)
            {
                t=(t2+t1)/2;
                k=f(t);
                if(k>y) t2=t;
                else t1=t;
            }
            cout<<fixed<<setprecision(4)<<t<<endl;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值