杭电acm2199二分法

Can you solve this equation?

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

  • 题目大意:求所给方程的解,很显然用二分法了,比较简单。但是在进行二分的时候,要注意将等号要放在大于y的情况下,否则会出现二分出来的值要比所给的参考数据要大。因此,二分的时候,等于的情况可以根据所给的测试数据进行判定。*
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
const double esp=1e-10;
int F(double m)
{
    return 8*pow(m,4)+7*pow(m,3)+2*pow(m,2)+3*m+6;
}
int main()
{
   int T;
   double low,high,x,y,ans;
   cin>>T;
   while(T--)
   {
      scanf("%lf",&y);
      low=0.0;
      high=100.0;
      if(y>F(100.0)||y<6)
      {
        printf("No solution!\n");
        continue;
      }
      while((high-low)>esp)
      {
        x=(low+high)/2.0;
        ans=F(x);
        if(ans<y)//根据所给答案进行确定边界 
           low=x+1e-10;
        else 
           high=x-1e-10;
      }
      printf("%.4lf\n",x);  
   }    
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值