杭电acm2289二分法

Cup

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10859 Accepted Submission(s): 3355

Problem Description

The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?

The radius of the cup’s top and bottom circle is known, the cup’s height is also known.

Input

The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

  1. T ≤ 20.
  2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
  3. r ≤ R.
  4. r, R, H, V are separated by ONE whitespace.
  5. There is NO empty line between two neighboring cases.

Output

For each test case, output the height of hot water on a single line. Please round it to six fractional digits.

Sample Input

1
100 100 100 3141562

Sample Output

99.999024

题目大意:有一个圆台型的杯子,已知杯子上底面,下地面的半径,杯子的高和水的体积,求这些水装到这个被子里面的高?

分析:显然二分法,但是要注意所给圆台上,下地面的半径不要弄反了,(这道题所给的测试数据上,下地面半径相同,很容易忽略杯子是圆台型的)。要用相似求出水装进去上底面的半径,u=h/H*(R-r)+r 。这道题特别类似杭电2199的二分法:
[https://blog.csdn.net/weixin_42917994/article/details/81662223]

#include<iostream>
#include<cstdio>
#include<cmath>
#define PI acos(-1.0) //acos是反三角
using namespace std;
double r,R,H,V;
double F(double h)
{
    double u=h/H*(R-r)+r;//R上面半径,r下面半径 
    return (1.0/3)*PI*h*(u*u+u*r+r*r)-V;//(1/3)的值为0,(1.0/3)的值才有效
}
int main()
{
   int T;
   cin>>T;
   while(T--)
   {
     cin>>r>>R>>H>>V; 
     double low,high,mid;
     low=0;
     high=H;
     while(high-low>1e-9)
     {
        mid=(low+high)/2;
        if(F(mid)>0)
          high=mid;
        else
          low=mid;
     }
     printf("%.6f\n",mid);
   }
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值