acm 2 1002 二分查找

1.1002

2.

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 《= x 《=100) Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input
  
  
2<br>100<br>200

Sample Output
  
  
-74.4291<br>-178.8534

Author
Redow

3.基本题意,对于给定的方程,找出确定范围内的最小值x

4.F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x ,分析方程,对于x的部分求导,导数小于0递减,倒数大于0递增,找到导数中的拐点,拐点处函数值最小,使用二分法查找

5.

#include<iostream>
#include<vector>
#include<algorithm>
#include<numeric>
#include<string.h>
#include<sstream>
#include<string>
#include<map>
#include<queue>
#include<iomanip>
using namespace std;
double f(double x)
{
    double l;
    l=42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x;
    return l;
}
double f1(double x)
{
    double l;
    l=6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x;
    return l;
}
int main()
{
    double n,i,k,z,l,e;
    double t,t1,t2;
    double x,y;
    cin>>n;
    while(n--)
    {
            cin>>y;
            t1=0;
            t2=100;
            while(t2-t1>0.0000001)
            {
                t=(t2+t1)/2;
                k=f(t)-y;
                if(k>0) t2=t;
                else t1=t;
            }
            z=f1(t)-y*t;
            cout<<fixed<<setprecision(4)<<z<<endl;


    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值