acm 2 1016 Red and Black

1.1016

2.

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13

3.@是一个人的起始位置,#不可以走,. 可以走,求出可以走的个数

4.深度搜索,递归

5.

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<queue>
#include<iomanip>
using namespace std;
int n,m;
char map[30][30];
struct ans
{
    int x;
    int y;
}n1,n2;
int ww(int a,int b)
{
    if(a>0&&a<=m&&b>0&&b<=n)
     return 1;
    return 0;
}
int BFS(int k,int z)
{
    int num=0,i;
    n1.x=k;
    n1.y=z;
    int disx[6]={-1,1,0,0};
    int disy[6]={0,0,-1,1};
    queue<ans> Q;
    Q.push(n1);
    while(!Q.empty())
    {
        n1=Q.front();
        Q.pop();
        for(i=0;i<4;i++)
        {
            n2.x=n1.x+disx[i];
            n2.y=n1.y+disy[i];
            if(ww(n2.x,n2.y)&&map[n2.x][n2.y]=='.')
            {
                num++;
                Q.push(n2);
                map[n2.x][n2.y]='#';
            }
        }
    }
    return num+1;
}


int main()
{
        int j,i,t,k,z;
    char x;
    while(cin>>n>>m&&n!=0||m!=0)
    {
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='@') {k=i;z=j;}
            }
        }
        t=BFS(k,z);
        cout<<t<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值