一道图论题目pku2263“Heavy Cargo”我还是用floyid算法

虽然floyid算法效率不高,三重循环,但是比较容易理解,通过适当的剪支还是可以 提高效率的。但是比赛时间有限,而且时间给的也够,因此我的算法的时间复杂度是O(n*n*n)。

我的代码:

/*
Heavy Cargo
Time Limit:1000MS  Memory Limit:65536K
Total Submit:225 Accepted:140

Description
Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive.

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities.


Input
The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network.
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions.
The last line of the test case contains two city names: start and destination.
Input will be terminated by two values of 0 for n and r.

Output
For each test case, print three lines:


a line saying "Scenario #x" where x is the number of the test case

a line saying "y tons" where y is the maximum possible load

a blank line

Sample Input


4 3
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Muenchen
5 5
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Hamburg 220
Hamburg Muenchen 170
Muenchen Karlsruhe
0 0


Sample Output


Scenario #1
80 tons

Scenario #2
170 tons


Source
Ulm Local 1998
*/
#include "iostream"
#include "memory"

using namespace std;
int main()
{
 int n,r,w,dis[200][200],t=1,flag=0,i,j,k,z=0,min,max;
 char ch[30];
 char p[200][30];
 while(cin>>n>>r&&n>=2&&n<=200&&r>=1&&r<=19900)
 {
  memset(p,'a',sizeof(p));
  memset(dis,0,sizeof(dis));
  for(;r-1>=0;r--)
  {
   cin>>ch;
   if(p[0][0]=='a')
   {
    strcpy(p[0],ch);
    z++;
   }
   for(i=0;i<z;i++)
   {
    if(!strcmp(p[i],ch))
    {
     flag=1;
     break;
    }
   }
   if(!flag)
   { 
    i++;
    strcpy(p[z],ch);
    z++;
   }
   flag=0;
   cin>>ch;
   for(j=0;j<z;j++)
   {
    if(!strcmp(p[j],ch))
    {
     flag=1;
     break;
    }
   }
   if(!flag)
   {
    strcpy(p[z],ch);
    z++;
   }
   flag=0;
   cin>>w;
   dis[i][j]=w;
   dis[j][i]=dis[i][j];
  }
  for(k=0;k<n;k++)
   for(i=0;i<n;i++)
    for(j=0;j<n;j++)
    {
     if(dis[i][k]>dis[k][j])
      min=dis[k][j];
     else
      min=dis[i][k];
     if(dis[i][j]>min)
      max=dis[i][j];
     else
      max=min;
     dis[i][j]=max;
    }
  cin>>ch;
  for(i=0;i<z;i++)
  {
   if(!strcmp(p[i],ch))
   {
    break;
   }
  }
  cin>>ch;
  for(j=0;j<z;j++)
  {
   if(!strcmp(p[j],ch))
   {
    break;
   }
  }
  cout<<"Scenario #"<<t<<endl;
  cout<<dis[i][j]<<" tons"<<endl;
  t++;
  z=0;
 }
 return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值