Longest Ordered Subsequence
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 43879 | Accepted: 19357 |
Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7 1 7 3 5 9 4 8
Sample Output
4
题意:求出最长上升子序列
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 1005
using namespace std;
int main()
{
int n;
while(~scanf("%d",&n))
{
int arr[MAXN];
int ans[MAXN];
int res=1;
memset(arr,0,sizeof(arr));
for(int i=0;i<=n;i++)
ans[i]=1; //因为最长上升子序列中最小为长度为1,所以初始化为1
for(int i=0;i<n;i++)
scanf("%d",&arr[i]);
for(int i=0;i<n;i++)
{
int mx=0;
for(int j=0;j<=i-1;j++)
{
if(arr[j]<arr[i] && ans[j]>mx) mx=ans[j];
}
ans[i]=mx+1;
if(ans[i]>res) res=ans[i];
}
printf("%d\n",res);
}
return 0;
}