输入正整数k,找到所有的正整数x>=y,使得1/k=1/x + 1/y; 样例输入: 2 12 样例输出: 2 1/2 = 1/6 + 1/3 1/

import java.util.*;

class Fenshu 
{
static Scanner scan=new Scanner(System.in);
public static void main(String[] args) 
{
int k;
int x,y;
int maxn=10000;
int[] a=new int[maxn];
int[] b=new int[maxn];
   k=scan.nextInt();
int count,i,j;
while(k!=0)
{
count=i=j=0;
Arrays.fill(a,0);
Arrays.fill(b,0);
for( y=k+1;y<=2*k;y++)
{
 if((y*k)%(y-k)==0)
   {

               count++;
  a[i++]=(y*k)/(y-k);
  b[j++]=y;

 }
}

for(int l=0;l<count;l++)
{
    System.out.print("1/");
System.out.print(k);
System.out.print("=");
System.out.print("1/");
System.out.print(a[l]);
System.out.print("+");
System.out.print("1/");
System.out.println(b[l]);
}
k=scan.nextInt();
}
}
}
  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值