Poj 3450

3 篇文章 0 订阅
Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0
Sample Output

abb

IDENTITY LOST

题意:求最大公共子串

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=2009;
int next[maxn];
char str[4009][205];
char st[maxn];
void getNext(int start,int len)
{
//    int i,k;
//    next[start]=start;
//    int end=start+len;
//    for(i=start+1,k=start;i<end;i++)
//    {
//        while(k>start&&str[0][k]!=str[0][i])
//        k=next[k-1];
//        if(str[0][k]==str[0][i])
//        k++;
//        next[i]=k;
//    }

    int pos = start - 1;
    int i = start, j = pos, end = start + len;
    next[start] = pos;
    while(i < end)
    {
        if(j == pos || str[0][i] == str[0][j])
        {
            i++;
            j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}
bool find(int start, int len,int index)
{
    int pos = start - 1;
    int i = start, j = 0, end = start + len;
    int length = strlen(str[index]);
    while(i < end && j < length)
    {
        if(i == pos || str[0][i] == str[index][j])
        {
            i++;
            j++;
        }
        else
            i = next[i];
    }
    if(i == end)
        return true;
    return false;

//     int length=strlen(str[index]);
//     int i,k;
//     int end=start+len;
//     for(i=0,k=start;i<length;i++)
//     {
//         while(k>start&&str[0][k]!=str[index][i])
//            k=next[k-1];
//            if(str[0][k]==str[index][i])
//            k++;
//
//     }
//     if(k==end)
//     return true;
//     return false;

}

int main()
{
    int n;
    scanf("%d",&n);
    while(scanf("%d",&n)!=EOF&&n)
    {

        for(int i=0; i<n; i++)
            scanf("%s",str[i]);
        int i,j;
        char ans[209]="IDENTITY LOST";
        int len=strlen(str[0]);
        bool stop=false;
        bool init=true;
        for(i=len; i>=1; i--)
        {

            for(j=0; j+i<=len; j++)
            {
                getNext(j,i);
                bool flag=true;
                for(int k=1; k<n; k++)
                {
                    if(!find(j,i,k))
                    {
                        flag=false;
                        break;
                    }
                }
                if(flag)
                {
                    if(init||strncmp(ans,str[0]+j,i)>0)
                    {
                        strncpy(ans,str[0]+j,i);
                        ans[i]='\0';
                        init=false;
                    }
                    stop=true;
                }
            }

            if(stop)
                break;
        }
        printf("%s\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值