OJ 2076 Problem F 多少个最大值?

Description

输入若干个int类型的整数,求它们的最大值及其个数。

Input

输入 若干个int类型的整数,至文件尾为止。

Output

输出只有一行:There are # maximum number &.

其中#是最大值的个数,&是最大值。

Sample Input

1 2 3 4 5 6 6 5 4 3 2 1 6 6 6

Sample Output

There are 5 maximum number 6.

HINT

不能使用数组。
max_element()函数包含在<algorithm>

Append Code

Accepted Code

#include <iostream>
#include <string>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    vector<int> n;
    int num;
    while (cin >> num) {
        n.push_back(num);
    }
    int num_max = 0;
    vector<int>::iterator Max = max_element(n.begin(), n.end()); 
    //max_element()函数包含在<algorithm>中
    for(int i = 0; i < n.size(); i++)
        if(*Max == n[i])
            num_max++;
        cout << "There are " << num_max << " maximum number " << *Max  << '.' << endl;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值