Problem F: 多少个最大值?

Problem F: 多少个最大值?

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 306   Solved: 180
[ Submit][ Status][ Web Board]

Description

输入若干个int类型的整数,求它们的最大值及其个数。

Input

输入 若干个int类型的整数,至文件尾为止。

Output

输出只有一行:There are # maximum number &.

其中#是最大值的个数,&是最大值。

Sample Input

1 2 3 4 5 6 6 5 4 3 2 1 6 6 6

Sample Output

There are 5 maximum number 6.

HINT

不能使用数组。

Append Code

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main()
{
    vector<int>v;
    int n;
    while(cin>>n)
    {
        v.push_back(n);
    }
    int cnt=0;
    vector<int>::iterator max_it = max_element(v.begin(), v.end());
    for(int i=0;i<v.size();i++)
        if(*max_it == v[i])
        cnt++;
    cout<<"There are "<<cnt<<" maximum number "<<*max_it<<"."<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值