poj2481-Cows

Cows

Description
Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

多的不加赘述,只说明一点:此题要求本质上是stars的变种。stars求的是位于左下角区域的星星数量,而将此题的s与e看作x坐标与y坐标的话,很明显求的就是左上角的奶牛数量(因为要求si<=sj 且ej≤ei)。因此将此题完全转化过去的关键在于,对输入的区间进行排序,之后按照y的降序排列,y相等时,按照x升序排列。

之后按照排序前的数据顺序判断即可,此处依靠id实现。具体还用到树状数组求和与修改,这是基本功能就不说了。

由于s与e可能为0,方便判断的情况下,分别+1。

#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;

struct node{
    int x,y,id;
}a[100005];

int val[100005],c[1000005];

int lowbit(int x){
    return x&(-x);
}

bool cmp(node a,node b){
    if (a.y!=b.y) {
        return a.y>b.y;
    }
    return a.x<b.x;
}

void add(int x,int num){
    while (x<=100000) {
        c[x]+=num;
        x+=lowbit(x);
    }
}

int sum(int x){
    int s=0;
    while (x) {
        s+=c[x];
        x-=lowbit(x);
    }
    return s;
}

int main(){
    int n;
    while (scanf("%d",&n),n) {
        memset(c, 0, sizeof(c));
        memset(a, 0, sizeof(a));
        for (int i=0; i<n; i++) {
            scanf("%d %d",&a[i].x,&a[i].y);
            a[i].id=i;
            a[i].x++;
            a[i].y++;
        }
        sort(a, a+n, cmp);
        val[a[0].id]=sum(a[0].x);
        add(a[0].x, 1);
        for (int i=1; i<n; i++) {
            if (a[i].x==a[i-1].x&&a[i].y==a[i-1].y) {
                val[a[i].id]=val[a[i-1].id];
            }
            else val[a[i].id]=sum(a[i].x);
            add(a[i].x,1);
        }
        printf("%d",val[0]);
        for (int i=1; i<n; i++) {
            printf(" %d",val[i]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值